Announcement

Collapse
No announcement yet.

Black screen via RDP or iDrac

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Black screen via RDP or iDrac

    Hi there, has anyone had the following problem on a Dell Poweredge server, when trying to RDP onto the server or go via iDrac once you try and login you get a black screen. You cannot do anything apart from reboot the server, once you reboot the server RDP will work for a period of time, a random period and then it's back to the black screen again and unable to login. Graphics and iDrac drivers are up to date.

  • #2
    Do you see the same thing when logging onto the server locally? Have you tried toggling from window to full screen mode and back again to try and force the display to refresh via Ctrl+Alt+Break.
    A recent poll suggests that 6 out of 7 dwarfs are not happy

    Comment


    • #3
      Hi there, we have tried everything, we even had someone onsite with a monitor and still the black screen. If we reboot the server it will work fine for a while and then this will return.

      Comment


      • #4
        Is the graphics adaptor fully supported by the installed version of Windows? Have you tried installing a dedicated graphics card?
        A recent poll suggests that 6 out of 7 dwarfs are not happy

        Comment


        • #5
          Yes its fully supported, have 6 servers the same spec all working fine.

          Comment


          • #6
            I've had this on some Dell servers a few years ago; the solution is in my Help Desk faq at work, I don't have remote access to it. I'll drop myself an email and post my suggestion tomorrow.

            UPDATE: What we've seen was cured by getting a copy of a reg key from a server that doesn't have the problem, and overwriting that on the server with the issue. The reg key is 'HK_Users\.Default\Control Panel\Colors'. Remote Registry should give you the access without having to log into the console. Worst case, plug in a monitor, keyboard & mouse for just this once.

            Also on the affected server, at the same reg key area, if you see extra entries 'MenuBar' and 'MenuHilight', delete them.

            We first encountered this on Server 2003, but thought this was worth keeping. Good luck.
            Last edited by RicklesP; 12th October 2017, 07:11. Reason: More info:
            *RicklesP*
            MSCA (2003/XP), Security+, CCNA

            ** Remember: credit where credit is due, and reputation points as appropriate **

            Comment


            • #7
              Hi there, not sure you fully understand, even at the console you get a black screen, its not just over RDP.

              Comment


              • #8
                Have you tried booting from installation media and repairing the OS?
                A recent poll suggests that 6 out of 7 dwarfs are not happy

                Comment


                • #9
                  I've uninstalled the graphics driver and will reboot at some point, going to run with a msoft driver and see what happens as 2 machine's that have the same problem have the same driver installed. The rest of the machine's are just using a msoft driver and they have been fine.

                  Comment


                  • #10
                    Problem persists after removing graphics driver, seems to begin after about 1 week, then the screenshot attached starts happening and then finally we will end up with a black screen only at some point.
                    Attached Files

                    Comment


                    • #11
                      Ok, ignore above, actually got in, took about 5 mins and the above is not the correct screenshot anyway, its usually the drive mappings part of the login it doesnt get past when it happens. I suspect it will happen over the next few days.

                      Comment


                      • #12
                        OK. Keep us posted.
                        A recent poll suggests that 6 out of 7 dwarfs are not happy

                        Comment

                        Working...
                        X