No announcement yet.

OS logs out RDP user regularly. I need that logon to persist.

  • Filter
  • Time
  • Show
Clear All
new posts

  • OS logs out RDP user regularly. I need that logon to persist.

    Hi All,
    Fresh installation of Server 2012 R2 Std OS

    I have an application that does not run as a service.
    I want this application to be 'always on'.
    I RDP into the box and launch the application and it stays up throughout the day.
    I kill the RDP session by simply closing the window, but I do not logoff.
    The logon session persists and the application continues to run.

    Typically, when I come in to work the next day, the application is not available, so I RDP into the box and it appears to be a brand new logon session. No applications are running.

    Just to be clear, I am not talking about a locked screen / screensaver timeout issue, but rather a session that is truly logged out.

    I have looked through the event viewer but haven't been able to make much out of what I see in there(inexperience). I can certainly provide details from the event viewer if needed.

    Thank you.
    Last edited by TwoScoops72; 20th September 2016, 14:01.

  • #2
    This looks like it may help you:

    Various options for configuring time-outs etc.
    A recent poll suggests that 6 out of 7 dwarfs are not happy


    • #3
      Thanks Blood.

      For the following items:
      • Set time limit for disconnected sessions
      • Set time limit for active but idle Remote Desktop Services sessions
      • Set time limit for active Remote Desktop Services sessions
      • Terminate session when time limits are reached
      • Set time limit for logoff of RemoteApp sessions
      All are set to 'not configured' and according to the notes in the help section, anything not configured allows the session to remain for an unlimited amount of time.

      I did make a change on the following which was suggested by someone further down the list:

      Local Security Policy -> Local Policies\Security Options
      Microsoft Network server: Amount of idle time required before suspending session
      15 minutes is default.

      I set this to the max which is 99999 minutes (208 days).
      I'll see how it goes tomorrow when I get in.