Announcement

Collapse
No announcement yet.

No GUI, can't use "Interact with desktop" for application in Cluster of Windows 2012

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • No GUI, can't use "Interact with desktop" for application in Cluster of Windows 2012

    Dear everybody
    We are using Windows 2003 Cluster (2 nodes) with our application as "Generic Application Resource", that means this application has GUI and we need to use the GUI to monitor, select options, stop/start somethings, etc, ... Cluster automatically start application in session 0 of active node.
    Now we upgrade to Windows 2012 Cluster, but now there is not session 0, we use "Generic Application Resource", even with "Interact with desktop" option of Cluster service but we can't see GUI of our application and we can't manage/control it, how ever I still see process of this application running in "Task manager".
    Should you please guide us to do, that means manage application GUI of "Generic Application Resource" of Cluster 2012.
    Thanks very much

  • #2
    Can you contact the software vendor to get their assistance? This sounds like an application issue.
    Regards,
    Jeremy

    Network Consultant/Engineer
    Baltimore - Washington area and beyond
    www.gma-cpa.com

    Comment


    • #3
      Originally posted by JeremyW View Post
      Can you contact the software vendor to get their assistance? This sounds like an application issue.
      Dear Jeremy
      It's not by application. It's new methology of Windows 2008/2012, difference than Windows 2003, now Windows 2008/2012 remove session 0.

      Comment


      • #4
        I understand it's a new "methodology" but that is not a Windows issue since it is by design. You should work with the application vendor to see if you can get it running properly on 2012.
        Regards,
        Jeremy

        Network Consultant/Engineer
        Baltimore - Washington area and beyond
        www.gma-cpa.com

        Comment


        • #5
          Originally posted by JeremyW View Post
          I understand it's a new "methodology" but that is not a Windows issue since it is by design. You should work with the application vendor to see if you can get it running properly on 2012.
          I found the way to resolve, that is using "Interactive Services Detection" service of Windows to show application in Session 0

          Comment


          • #6
            Excellent. Could you share how you did it so others can benefit?

            Thanks!
            Regards,
            Jeremy

            Network Consultant/Engineer
            Baltimore - Washington area and beyond
            www.gma-cpa.com

            Comment


            • #7
              Interactive Services detection is a Windows service - Start > Run > Services.msc

              I've come across other applications which are unable to present a user GUI unless it is started.
              A recent poll suggests that 6 out of 7 dwarfs are not happy

              Comment


              • #8
                Originally posted by Blood View Post
                Interactive Services detection is a Windows service - Start > Run > Services.msc

                I've come across other applications which are unable to present a user GUI unless it is started.
                Correct. This tool is not very friendly but it's acceptable.

                Comment


                • #9
                  Originally posted by thang_ngo_2002 View Post

                  I found the way to resolve, that is using "Interactive Services Detection" service of Windows to show application in Session 0

                  Thanks for sharing the answer!
                  Cheers,

                  Daniel Petri
                  Microsoft Most Valuable Professional - Active Directory Directory Services
                  MCSA/E, MCTS, MCITP, MCT

                  Comment


                  • #10
                    Hi Mr Thang_ngo_2002,

                    I also have the same issue. I try to start the service "interractive services detection" but my application resource which configured in cluster window 2008 have still not launched on desktop. Please help me to resolve this problem. Thank you so much

                    Comment


                    • #11
                      Dear AmE
                      You can see some applications via "interactive services detection" but some other you can't.
                      For example you add "calc.exe" to Generic Application Resource, you can launch when it's online, how ever for "notepad.exe", you can't launch when it's online
                      I don't know why also.

                      Comment


                      • #12
                        Dear Mr Thang and all,

                        I would like to thank you for your reply. I will run my service/application in window cluster 2008 but only I am not sure whether it run without GUI stably or not. Now I still face other issue. Before clients connect to my service by cluster IP (cluster window 2003, I added IP float cluster to cluster window 2003) but in cluster 2008, each service/application is required to assign unique IP (not same IP cluster).
                        1. In cluster 2003, when I manually switchover from A to B node, Ip cluster also move to B node but in cluster 2008, ip cluster is still on A node. Why this?
                        2. I can't add IP cluster into cluster or dependence of service. How to resolve this issue? With this change in cluster 2008, how do it work?
                        3. In this case, with IP cluster (same as cluster 2003) and IP of service (when I add service resourse), Can client connect to my service by cluster IP? or it must connect to my server by IP of service. If can connect to my service by cluster IP but when service moved to B node and cluster IP still on A node, client can access to service or not?
                        I cannot request clients to change new connection IP. I hope that you can support me to clear this issue.
                        Last edited by AmE; 15th October 2015, 16:40.

                        Comment

                        Working...
                        X