No announcement yet.

IP config gone

  • Filter
  • Time
  • Show
Clear All
new posts

  • IP config gone

    I set up a Windows teaming on a number of servers using a powershell script where my NIC team gets created and then IP gets set up with new-netIPaddress cmdlet as well as mask and gateway. The script also sets up DNS in another one-liner. After a couple of reboots the static IP config is gone although dns stays. This also messes up my RDS confuguration. When IP disappeares my RDS collection is gone as well? At first I thought it was a one off but it happened on 4 servers so far and chances are it happens on all afer a number of reboots. What's going on?

  • #2
    Can you post the script (change IPs if needed, but shouldn't be if private IP range)
    Anything in event logs?
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    IT Trainer / Consultant
    Ossian Ltd

    ** Remember to give credit where credit is due and leave reputation points where appropriate **


    • #3
      Nothing in the evant log. I checed the registry and I found the IP settings still there with correct values. Nothing special about the script. I'll post the script when I have access to the servers.


      • #4
        This is how it's done
        New-NetLbfoTeam-Name"Internal LAN"-TeamMembers eth1,eth2-TeamingModeSwitchIndependent-LoadBalancingAlgorithmTransportPorts-Confirm:$false
        Start-Sleep -s 10
        Get-NetAdapter|where{$_.Status -eq"Disconnected"} |Disable-NetAdapter-Confirm:$false
        New-NetIPAddress-InterfaceAlias"Internal LAN"-AddressFamilyIPv4-IPAddress""-PrefixLength"24"-DefaultGateway""
        Last edited by biggles77; 17th June 2015, 11:49. Reason: Increase font size to something readable and wrap in CODE


        • #5
          Is this a new script due to some networking change, or has it always worked? Are you using switches which are physically stacked with dedicated cables (and so are treated as a single switch for control purposes), or are they separate but still members of an etherchannel group? Your command shows the team being configured to work with the latter. What drivers are installed for the physical NICs in question?
          MSCA (2003/XP), Security+, CCNA

          ** Remember: credit where credit is due, and reputation points as appropriate **


          • #6
            It's a new script to help with automation of certain deployment tasks like configuring MS team in this case. Switches are separete in separate racks. The drivers are installed thrugh HP service pack for Proliant servers.


            • #7
              Try using Set-NetIPAddress instead of New-NetIPAddress.The documentation says that the default for new-netipaddress only puts it in the active store but when I run the command it shows both active and persistent. So I'm not sure what's going on there. The default for Set says it's both the active and the persistent.

              Network Consultant/Engineer
              Baltimore - Washington area and beyond