No announcement yet.

Server can not see external hard drives (USB)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Server can not see external hard drives (USB)

    This is a 2008 R@ server (Power Edge T710). I have 3 external hard drives for backups. About a week ago I realized that none of the backups work. Computer does not see any external HD or flash drives.
    Device manager shows the yellow warning sign and displays the following error message.
    "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)"

    For 2 days Dell's technicians tried to fix it, deleted drivers, tried different drivers..
    with no success. After 2 days they gave-up and replaced the mother board. Still
    same problem. Keyboard or mouse, plugged in the USB drives work fine.

    Event viewer shows that the server shutdown unexpected, due to a lost of power. The problem started right after this event.

    Last message from Dell was: "we do not any idea how to fix this issue".

    Any suggestions ?

    Thank you, very much.


  • #2
    Re: Server can not see external hard drives (USB)

    What driver is causing the issues?

    Any hidden devices with the same issue?

    If Dell are having issues with getting it to work with software then i would hazard a guess that your "power event" has possibly damaged the board in the server.

    Are you able to purchase a USB card and install that to check if it is the USB ports on the board that are faulty?

    I would presume you have tested multiple ports on the server?

    Have you ran sfc /scannow to check if there are any OS corrupted files?

    Have you run a chkdsk /f to check the disks?


    • #3
      Re: Server can not see external hard drives (USB)

      do the drives work on other computers ?
      Please do show your appreciation to those who assist you by leaving Rep Point


      • #4
        Re: Server can not see external hard drives (USB)

        I had a similar thing happen on an Acer after the local tech dicked around and did Deity knows what. It took a full O/S reinstall fix it unfortunately. No idea what the problem was but there was nothing in the Event Logs and unlike yours the Device Manager showed it to be all hunky dory (working correctly).

        I didn't think of it at the time but it might be worth finding out what Registry entries cover the USB ports and delete them. They should then be reinstall on reboot.
        Joined: 23rd December 2003
        Departed: 23rd December 2015