No announcement yet.

Domain User Executing An Executable UAC Issue

  • Filter
  • Time
  • Show
Clear All
new posts

  • Domain User Executing An Executable UAC Issue

    I've been running a program located in a folder in on the C: of my terminal server, which is part of a Domain. I've added certain domain users to the folder which have full access to the folder, sub folder, and files. I copied the shortcut of the executable to the desktop of certain users. It has ran fine for 2 years. I DID NOT have the UAC turned off.

    After Reinstalling the program because of an update, all of a sudden the UAC is popping up asking for admin credentials.

    I have been trouble shooting for 2 days, Long story short, i have now applied "everyone, domain users, a domain group i created for this app,even individual names" to the security tab, of that folder, sub folder, and files". I have even taken ownership of that folder with the domain group, it's still asking me for admin credentials. The folder was never shared before when it worked. I have even added a few name to the C: as well as that Group name to the C:.

    I tried to set the shortcut executable to launch as an administrator. Clicked on the advanced tab on properties, and selected run as administrator, but that doesn't work.

    I have this same setup on another server, i looked at the setup, and it was the same before i added all of the extra users, or took ownership, etc. And it works fine.

    Hope i explained well

    Last edited by Kobe 310; 3rd December 2014, 21:55.

  • #2
    Re: Domain User Executing An Executable UAC Issue

    If this happened after you updated the program, speak to the vendors and bring their support into the loop - have they changed anything which in turn affected UAC

    UAC is independent of permissions on the app exe or directory - as you probably know, you can disable it through group policy, but not for individual programs
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    IT Trainer / Consultant
    Ossian Ltd

    ** Remember to give credit where credit is due and leave reputation points where appropriate **


    • #3
      Re: Domain User Executing An Executable UAC Issue

      I tried that, was on the phone for an hour. They couldn't figure it out.

      I'm assuming i've done everything right, and nothing more i can do.

      Turned off UAC on domain administrator and it worked. However i'm assuming that i don't want to keep this turned off correct?
      Last edited by Kobe 310; 4th December 2014, 14:05.