No announcement yet.

Access to Samba\vfiler share via shortname

  • Filter
  • Time
  • Show
Clear All
new posts

  • Access to Samba\vfiler share via shortname

    I wasn't sure which section to post this under as it occurs on different operating Systems (Windows XP SP3, Windows 7, Windows 8, Server 2003, Server 200 and is random.
    Basically, some of our end users experience problems accessing shares to a vfiler for example with shortname \\example\share.
    They can access this specific share via ip address or fqdn \\example.domain.local\share. The user can even access \\example and be
    able to view shares there but when clicking on the share it comes back with network error or access denied.
    This does not happen to all users at a time and on the same workstations\servers and there are no specific times. On the end users workstation DNS and wins is working, they have
    no problems accessing other vfilers or F&P Windows shares.
    I tried all flushing DNS and wins cache, tried rebuilding CSC (Offline files) to no avail. We don't have this enabled in our environment in any case
    but gave it a try.
    One way I got it working via shortname is by adding a new security group to the security permissions on the share. The group only had my account as a member
    and exsiting groups remained. After this the end user was able to map via shortname.
    I've tried many things and just can't figure this out or where to look. My team doesn't manage the vfilers or samba shares so
    can't look at the logs or anything.

    Another scenarion I have is for a Samba share, very similar situation but this time its accessing the share on a Windows 2008 R2 server.
    Basically similar symptoms, can't access via shortname, get 'Network Error', tried several things, even Windows Network Diagnostic
    where it states that "The remote device or resource won't accept the connection', "The device or resource (samba) is not setup to accept connection
    on port "The File and printer sharing (SMB)". Port 139 is open, can access other shares on different storage devices successfully.
    What's weird is that after some time, An hour, 2 or 3 later functionality returns without any changes. Obviously restarting the server resolved this quicker.
    There are no scheduled tasks or tasks running in the background, Windows firewall is disabled, disabled AV etc.

    I managed to get a log from this Samba device but not sure if its related or not.
    [[email protected]] [09:30:52] /var/log/samba
    # tail /var/adm/messages
    Apr 3 08:33:06 samba adbindd[24524]: [ID 323999 auth.error] ERROR samba.adbindd2 Task exit with cims error: Error sending response: Broken pipe
    Apr 3 09:10:07 samba adbindd[24524]: [ID 323999 auth.error] ERROR samba.adbindd2 Task exit with cims error: Error sending response: Broken pipe

    Only other thing I can think of is that is may have something to do with the device, folder redirection, cache or something of that sort.
    I'm stuck, anyone have any ideas. I would like to know what else to try if the issue re-coccurs.