No announcement yet.

Configure Unmapped UNIX User Access

  • Filter
  • Time
  • Show
Clear All
new posts

  • Configure Unmapped UNIX User Access

    This is how I go about it (after adding the NFS role service).

    1. Ceate a folder named NFS on Server01
    2. Right-click C:\NFS, choose properties
    3. On the NFS sharing tab, click Manage NFS Sharing
    4. Tick Share this Folder

    5. Untick Kerberos v5 integrity and authentication
    6. Untick Kerberos vs authentication
    7. Click Permissions

    8. Click Add, in Add names box, type the IP address of a Ubuntu 12.04 machine, change type of access to Read-Write for that ip address, and then click OK, and OK again.

    9. Back at the NFS Advanced Sharing dialog box, click Apply and then OK again, then close the properties for NFS.

    10. On the Linux machine, created an empty folder called NFS, and then map the nfs share

    sudo mount /home/nfs

    11. The folder is mounted properly

    But when I try to access it, I get the following error "You do not have the permissions necessary to view the contents of nfs"

    What am I doing wrong?
    I don't want anonymous access, I want unmapped Unix User access.

  • #2
    Re: Configure Unmapped UNIX User Access

    Found out that I need to enable root access. I still can not access the mounted share from the Ubuntu Explorer, but I am able to access it from the terminal (only when running sudo -s first, to gain root privileges in the terminal).