No announcement yet.

VAMT 3.0 on 2008 R2 unable to import product keys

  • Filter
  • Time
  • Show
Clear All
new posts

  • VAMT 3.0 on 2008 R2 unable to import product keys

    Hi all!
    Have decided to finally move our organization towards Office 2010 and I'm now experiencing the joys of Microsoft's new "Volume Activation 2.0" designed to "Improve the volume customer experience" (yeah, right).

    Anyhow. I've set up VAMT 3.0 on a test system running 2008 R2. I used the ADK installer (online) for this and selected to install VAMT and SQL Express. I've also made sure that .NET 3.5.1 and .NET 4 were installed.

    Immediately after installing VAMT 3.0 and going through the quick wizard to set up and connect to the SQL database I tried importing a product key.

    Took about a minute for the product key to be verified after which I am provided with the following error:

    Volume Activation Management Tool has encountered an error
    String or binary data would be truncated.
    The statement has been terminated.

    After clicking "OK" to that error I then receive a notice that "1 product key was successfully verified and added to VAMT." - which isn't really the case as my "Product Keys" listing continues to be empty.

    I've tried re-creating the database, no luck.

    Can't seem to find any information with respect to this problem online either.

    Would highly appreciate some feedback from anyone who has encountered either this or a similar error with VAMT.

    Thank you in advance!

    (P.S. this is a fresh install of 2008 R2. Immediately after installing the OS from my 2008 R2 SP1 media I ran through the usual Windows Update routine after which I ran the ADK installer. This is therefore a very bare installation.)

  • #2
    Re: VAMT 3.0 on 2008 R2 unable to import product keys

    Just a small update.

    I've reinstalled my test system from scratch. Just in case.

    -> Installed 2008 R8 SP1
    -> Ran Windows Update
    -> Installed .NET Framework 4 & Updated
    -> Installed .NET Framework 3.5.1 & Updated
    -> Ran ADKsetup and installed VAMT 3.0 and SQL Express
    -> Ran VAMT 3.0 and set up new database
    -> Try to add product key & same error as described above

    This is as plain an install as it is possible. And my second attempt.

    So either Microsoft's little "DRM" scheme is, like every other DRM scheme frankly, completely broken and a waste of time.

    Or I'm missing out on something.

    I'd go with the later but I have checked the system requirements and do not see a single other component which is required. (Powershell is also at V3 but that shouldn't be of any relevance since I'm not utilizing any Powershell cmdlets at this point of time.)

    Guess I can shelf our Office 2010 plans for now...