Announcement

Collapse
No announcement yet.

Remote desktop services secondary server

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Remote desktop services secondary server

    I am having an issue configuring remoteapps. I have two servers, Server 2011 SBS, fully configure and running great. The second server, Server 2008R2, is a backup server hosting a company db. We would like to configure remoteapps on the R2 server.

    I have added the role and configuration and is running and accessable from the R2 server.

    Can it be accessible from outside the network, over the internet?

    Any guidance would very much be appriciated!

    Thank you
    Last edited by seanmff; 30th November 2012, 17:07. Reason: clarify title

  • #2
    Re: Remote desktop services on secondary server not accessible from internet

    Presumably the primary server is accessible from the internet on port 3389, but IIRC RDS can be published over port 443
    Alternatively you can add an additional remote desktop (not remote apps) port using a registry tweak and open that port on your router/firewall
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: Remote desktop services secondary server

      Thanks for the reply. The Primary server is accessible from the internet hosting exchange, RRW. 443 is forwarded it the primary server.

      Comment


      • #4
        Re: Remote desktop services secondary server

        To make RemoteApps available on the Internet you need the RD Gateway service installed somewhere.... and since you have an SBS 2011 server it's already installed and running there. But I've never tried to get this setup running on an SBS 2011 server before.

        To get the management utility on the SBS server for the RD Gateway: http://support.microsoft.com/kb/2472211

        To configure the RD Gateway for RemoteApp:
        http://technet.microsoft.com/en-us/l.../cc772415.aspx

        Someone else that seems to have gotten it done:
        http://blog.mpecsinc.ca/2011/07/sbs-...to-set-up.html

        Dealing with a somewhat related issue:
        http://forums.petri.com/showthread.php?t=55278
        Regards,
        Jeremy

        Network Consultant/Engineer
        Baltimore - Washington area and beyond
        www.gma-cpa.com

        Comment


        • #5
          Re: Remote desktop services secondary server

          Thanks Jeremy,

          I've read the articles, thank you.

          In the article: Someone else that seems to have gotten it done:
          http://blog.mpecsinc.ca/2011/07/sbs-...to-set-up.html

          1. Make MIME changes for .RDP (Charlie's SBS 08 book has this)
          2. Edit RWW/RWA Links in SBS Console

          It kind of falls apart, so I'm still suck.

          Sean

          Comment


          • #6
            Re: Remote desktop services secondary server

            If it helps:

            Remote Web Access is configured and running on my SBS server. When I log onto rdweb using https://server/rdweb and click on the Configuration tab to specify the name of my Server 2008 R2 server I get an error, "RD Web Access was not able to access "server2008r2". Verify that the computer account of the RD web access server is added to the TS Web access computers security group on the RD session host server." Thank you

            Comment


            • #7
              Re: Remote desktop services secondary server

              It sounds like the person that got it working didn't use RD Web. They just created the RDP files, configured them with the RD Gateway settings, and then posted links to the RDP files on the RWW site.
              Regards,
              Jeremy

              Network Consultant/Engineer
              Baltimore - Washington area and beyond
              www.gma-cpa.com

              Comment

              Working...
              X