No announcement yet.

Mapped drive in shortcut not workiing

  • Filter
  • Time
  • Show
Clear All
new posts

  • Mapped drive in shortcut not workiing


    I have a 2008 R2 server that is not a domain controller - currently just acting as a file, DNS and DHCP server for the office. The is one shared folder mapped as drive X. I have enabled the Guest account to allow easy access to the server.

    We have a mixture of Windows 7 and Windows XP machine and there is no issue with the mapped network drive except for the following issue.

    We use MYOB accounting and the users have a shortcut on their desktop that point to MYOB and the associated company file

    C:\P19\myob.exe "X:\myob\myob.myo"

    The first time the machine starts up, I open up the shared drive to make sure the connection works and I can browse the shared folder content with full access.
    If I then click on the MYOB shortcut, MYOB does not find the file and prompts me to choose the file manually.

    Once MYOB has made the first connection successfully, then all subsequent clicks on the shortcut work

    Some machines have multiple shortcuts for different MYOB files and once one has been opened, then all work, but it always requires the first file to be manually selected. I have tried changing the order of which shortcut I click on first but same result.

    Thank in advance

  • #2
    Re: Mapped drive in shortcut not workiing

    I'm guessing here but maybe the guest account requires manual intervention for the first connection/mapped drive?

    Can you test sharing this location using username/password and see if it is different maybe?

    Please read this before you post:

    Quis custodiet ipsos custodes?


    • #3
      Re: Mapped drive in shortcut not workiing

      Thanks for your reply.

      I only enabled the Guess account in an attempt to try and solve this problem so initially it was set up with username/password.


      • #4
        Re: Mapped drive in shortcut not workiing

        Is the issue only with the windows 7 computers, or also with XP computers.
        Are the computers client in a domain?

        Use Process Explorer to find out what happens.

        It is not an answer, but can you try this shortcut as possible work around:
        cmd.exe /c "cd /d "X:\myob"&&start ""/b "C:\P19\myob.exe" "X:\myob\myob.myo""
        Last edited by Rems; 8th August 2012, 10:26.

        This posting is provided "AS IS" with no warranties, and confers no rights.


        ** Remember to give credit where credit's due **
        and leave Reputation Points for meaningful posts


        • #5
          Re: Mapped drive in shortcut not workiing

          It happens on both XP and Win7 and they are NOT part of a domain.

          The 2008 R2 server is the only server in the office and it is NOT a DC.