Announcement

Collapse
No announcement yet.

Abcpdf 8 64 bit with ASP.Net - Missing images in PDF for some users

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Abcpdf 8 64 bit with ASP.Net - Missing images in PDF for some users

    We're using ABCPDF.Net 8 to generate PDF documents for users. The HTML source is loaded directly as a string and images are defined in the HTML with the full path. Example:
    <img id="img1" src="file://D:/trakit/images/cl_logo.gif" alt="" />

    This works beautifully and we have about 200 users generating PDFs with no problem.

    The problem is that a few handful of users are not getting the images in the PDF. The images are replaced by the image placeholder that is shown by IE when an image is not found.

    This happens consistently for some users only. I cannot figure out what is wrong as the PDF is generated server-side and should not have anything to do with the user's browser settings. I agree that the page/code is running under the user's permissions (we use windows authentication), but why should this affect PDF image generation? Below is the code snippet to generate the PDF:
    PDFDoc.Rect.Inset(20, 20)
    PDFDoc.Page = PDFDoc.AddPage()
    li_PDFID = PDFDoc.AddImageHtml(as_HTML, True, 1050, True)

    While PDFDoc.Chainable(li_PDFID)
    PDFDoc.Page = PDFDoc.AddPage()
    li_PDFID = PDFDoc.AddImageToChain(li_PDFID)
    End While

    For li_Loop = 1 To PDFDoc.PageCount
    PDFDoc.PageNumber = li_Loop
    PDFDoc.Flatten()
    Next

    Return PDFDoc.GetData()

    Any help will be greatly appreciated.

    Thanks.

    Update: Just found that if the user users another browser (such as Firefox), the images then generate fine. This narrows down the problem to IE 7/8 on the user's computer. Any suggestions?

    Also i added the following code found in another post:
    theDoc.SetInfo(0, "CheckBgImages", "1");
    theDoc.SetInfo(0, "RenderDelay", "5000"); // You can change this value, just an initial test.

    But it still doesn't work. Im badly stuck on this. Pls help
    Thanks,
    Bhavtosh

  • #2
    Re: Abcpdf 8 64 bit with ASP.Net - Missing images in PDF for some users

    do you use the same version of IE Across your entire fleet ?
    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

    Comment


    • #3
      Re: Abcpdf 8 64 bit with ASP.Net - Missing images in PDF for some users

      yes, everyone in team using IE is facing the issue
      Thanks,
      Bhavtosh

      Comment


      • #4
        Re: Abcpdf 8 64 bit with ASP.Net - Missing images in PDF for some users

        same version of IE though ?
        like - is everyone using IE8, or 9 ? Or are there different versions?

        On the computer where someone is having trouble, can you try resetting IE to it's defaults ?
        Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

        Comment


        • #5
          Re: Abcpdf 8 64 bit with ASP.Net - Missing images in PDF for some users

          Originally posted by tehcamel View Post
          same version of IE though ?
          like - is everyone using IE8, or 9 ? Or are there different versions?

          On the computer where someone is having trouble, can you try resetting IE to it's defaults ?
          All such investigations are done. My query is very much specific to AbcPdf 8 64 bit
          Thanks,
          Bhavtosh

          Comment


          • #6
            Re: Abcpdf 8 64 bit with ASP.Net - Missing images in PDF for some users

            Originally posted by bhavtosh View Post
            All such investigations are done. My query is very much specific to AbcPdf 8 64 bit
            In which case their support pages seems like a good starting point
            http://www.websupergoo.com/support.htm


            Note people ask you questions to try to (a) understand your issue fully and (b) help you solve it. Getting their heads bitten off for asking a legitimate question does not encourage more responses. Since you state that the problem affects IE users only, and mention two versions of IE in your original post, asking for moe information on that point is very reasonable.

            Additional questions - has the problem just started, or has it always affected these users?
            If it has just started, what has changed (both server and client side)?
            Tom Jones
            MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
            PhD, MSc, FIAP, MIITT
            IT Trainer / Consultant
            Ossian Ltd
            Scotland

            ** Remember to give credit where credit is due and leave reputation points where appropriate **

            Comment


            • #7
              Re: Abcpdf 8 64 bit with ASP.Net - Missing images in PDF for some users

              Originally posted by Ossian View Post
              In which case their support pages seems like a good starting point
              http://www.websupergoo.com/support.htm


              Note people ask you questions to try to (a) understand your issue fully and (b) help you solve it. Getting their heads bitten off for asking a legitimate question does not encourage more responses. Since you state that the problem affects IE users only, and mention two versions of IE in your original post, asking for moe information on that point is very reasonable.

              Additional questions - has the problem just started, or has it always affected these users?
              If it has just started, what has changed (both server and client side)?
              I understand your concern and im not biting any head here. I seek solution as same way as others do here. AbcPdf support has not been much of help so i came here. Pls dont assume that i mentioned 2 versions of IE [7/8] and i will correct the query here is that error is with IE 9.

              Looking forward for some advice
              Thanks,
              Bhavtosh

              Comment


              • #8
                Re: Abcpdf 8 64 bit with ASP.Net - Missing images in PDF for some users

                Originally posted by bhavtosh View Post
                Update: Just found that if the user users another browser (such as Firefox), the images then generate fine. This narrows down the problem to IE 7/8 on the user's computer. Any suggestions?
                Pls dont assume that i mentioned 2 versions of IE [7/8] and i will correct the query here is that error is with IE 9
                I give up
                Tom Jones
                MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
                PhD, MSc, FIAP, MIITT
                IT Trainer / Consultant
                Ossian Ltd
                Scotland

                ** Remember to give credit where credit is due and leave reputation points where appropriate **

                Comment


                • #9
                  Re: Abcpdf 8 64 bit with ASP.Net - Missing images in PDF for some users

                  Originally posted by Ossian View Post
                  I give up
                  NP one of us had to
                  Thanks,
                  Bhavtosh

                  Comment


                  • #10
                    Re: Abcpdf 8 64 bit with ASP.Net - Missing images in PDF for some users

                    Have you tried going back one version to see if that fixes the issue?

                    We have three staff working here who use I.E.9 to access a website so they can manipulate data etc. Two of them were having problems while the other was not. Reverting to I.E.8 solved it. The three machines are identical - so I have no idea why this issue arose in the first place.
                    A recent poll suggests that 6 out of 7 dwarfs are not happy

                    Comment

                    Working...
                    X