No announcement yet.

Replication not working over VPN multiple servers

  • Filter
  • Time
  • Show
Clear All
new posts

  • Replication not working over VPN multiple servers

    I have a master domain controller at our main office and I'm trying to setup multiple secondary domain controllers. My master holds the fmso role and is set to forest wide and domain wide.

    I was able to set up the first domain controller no problem. However, I have not been able to get any other domain controller to replicate with it.

    I get a silly error message when I try to replicate with the master that says "The naming context for the specified replication operation is invalid". This is when I try to force a replication in Sites and Services.

    I've also tried using repadmin to force a replication and I get "The DSA object is not available".

    I've tried demoting and promoting about 500 times. On the secondary dc I have the master domain controller as the primary dns and it's ip address (not as the secondary.

    I am not using any windows firewalls or router firewalls.

    I've tried metadata cleanup on both servers to no avail.

    I've tried setting the Burflags registry entry on all secondary DCs to D2 and restarting the FRS service and that hasn't worked. (the master is D4)

    I've gone through all DNS records on the master DC and everything is correct.

    I've checked to make sure the DNS alias is correct for the secondary DC and made sure it's properly registered in DNS which it is.

    I've tried the Netdom command to reset the passwords on both controllers. Nothing.

    Each DC has a proper subnet, site and site link in AD sites and servers.

    I can ping each server from anywhere on any DC.

    I've tried dcdiag /fix ipconfig /flushdns, ipconfig /registerdns and 80 million other useless commands. Nada

    I can't map using the fqdn from the master to the secondary without getting a useless error message that says "Logon Failure: the target account name is incorrect"

    The CNAME is correct in DNS, but adding the server as a name server to both zones it can't resolve the IP. Why???

    Please help. I'm at wits end. This stuff just isn't working.

    Using 2008 R2 on all servers
    Last edited by Alcyone; 23rd May 2012, 17:25.

  • #2
    Re: Replication not working over VPN multiple servers

    Nevermind. I figured out what the problem is and I'm a complete idiot. I had 2 VPN connections back to the main site with the same IP scheme and subnet. So I basically had 2 servers with the same IP.