Announcement

Collapse
No announcement yet.

RDP in Server 2008 R1 DOA

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RDP in Server 2008 R1 DOA

    Sorry This sounds like a Newbie post (it is I suppose)

    I have a standalone Server with 2008 R1 x64 Install built April 2010 (12 Workstations in domain 3 x W7 (64Bit) and 9 XP ) which suddenly stopped giving me RDP connections after a user caused an electrical fault.

    I decided to reformat the whole Server as I couldn't get RDP back after trying everything suggested on the Net. After spending a whole public holiday there and re-formatting the server and re-joining all the users back on the domain, RDP was still dead on a fresh install.

    Luckily I have logmein so I am still able to log in remotely, but as I am not based on site I need RDP for the Local senior user to log on and do simple things. I also like to have a Back door in case the Logmein server is ever down.

    I have tried everything on the net, everything suggested by Microsoft, I am at my wits end as I cant understand how something that used to work flawlessly now doesn't. I can't log in remotely from inside the premises or from Outside with my DynDns Host name.

    Some Background things:

    I can Ping the Hostname of the Server (server.XXXXX.local or simply Server ) but can't ping the IP address of the server from any Workstation (10.0.0.1)

    I can RD from the server to any Workstation and from any workstation to any other workstation but not to the Server itself.

    I get no clues in the event viewer as to what's blocking RDP, It's just as though it's not switched on.

    I have tried both a Custom TCP port like 19977 like I used to always use for extra security but ended up putting it back to 3389 (Default)

    I can switch off the Firewall and it makes no difference so it's not Firewall issue (I do have exclusion for TCP ports 3389 and 19977

    I switch off Anti-Virus (Avast Business) on the Server also makes no difference

    I get an error in Event viewer that DCHP is enabled for IPV6 even though I have disabled IPV6 interface through Network connections and done the registry trick to disable the IPV6 Interface warning messages.

    Another Error I see is a CA certificate error which I seem to have fixed by issueing a new Certificate, but I notice that the Remove Desktop certificate expires in Sep 2012? I can't seem to re-issue the certificate as that option is greyed out. All I can do is find Certificate or Delete certificate.

    I am the administrator (I have tried with my regular login with admin privileges as well, so it's not a User issue.

    This server basically only handles the Accounts package for my customer and assigns DHCP and DNS functions. It is not stressed at all.

    It's not a NAT issue as the router saettings haven't changed and I cant RD in from any workstation on the domain either so it's something on the RD/TS engine.

    I am wondering if this issue is unique to Server 2008 R1 and if I used an R2 install/Upgrade would it be guaranteed to work. I don't want to do all that work again to find it still had no RDP connection.

    Any suggestions (even the wierd ones) will be appreciated. I have done everything else suggested all over the net and I'm now desperate.

  • #2
    Re: RDP in Server 2008 R1 DOA

    Do you use RD License system? Maybe your RDP License is expired,etc so first uninstall your RD License.

    I am not expert but event log show any error?

    Comment


    • #3
      Re: RDP in Server 2008 R1 DOA

      Nope I tried that as well. But I am just using the Standard Remote Desktop for Administration function which allows 2 Simultaneous users and no Licencing.

      For the record I did try installing the Terminal services function with the 120 Day trial but had no luck there either. There seems to be something wrong with RD on 2008 R1. MS Mention Hotfixes but the downloads appear to all relate to Server 2003.

      Comment


      • #4
        Re: RDP in Server 2008 R1 DOA

        What I find interesting is you say that you rebuilt the server from scratch and the problem still persists. That would make me think its a group policy thing but why would a power failure cause that. Maybe some data corruption when the system went down?

        I had a problem like this, similar symptoms anyway. Even though the firewall said it was disabled it wasn't truly until I issued the following command:

        Netsh advfirewall set allprofiles state off

        You can turn it back on changing state off to state on.

        Worth a try?

        Comment


        • #5
          Re: RDP in Server 2008 R1 DOA

          Thanks for the advice, I will give it a try when all the users are off tonight. When I say small Electrical problem, it was so severe it tripped the Online UPS when the Telephone management system caused a dead short on the UPS Output circuit. It was the only thing I hadn't tried. This setup has been a nightmare with really weird network issues on one workstation and the server, but that's a long story....

          Comment


          • #6
            Re: RDP in Server 2008 R1 DOA

            OK, That took me one step closer. It now asks for my Password whereas before It would not. But it still won't let me in. I got in with Logmein and checked the event viewer and got this event:

            The Terminal Server security layer detected an error in the protocol stream and has disconnected the client.

            I tried to log in from my office (They are 20km away).

            Comment


            • #7
              Re: RDP in Server 2008 R1 DOA

              Originally posted by Mtech61 View Post
              OK, That took me one step closer. It now asks for my Password whereas before It would not. But it still won't let me in. I got in with Logmein and checked the event viewer and got this event:

              The Terminal Server security layer detected an error in the protocol stream and has disconnected the client.

              I tried to log in from my office (They are 20km away).


              Seems you've some problem in Terminal Security option..

              Change your terminal security to Normal or change to other option and also if possible then send a screenshot of your RDP setting(My Computer >> Properties >> RDP Setting)



              - Problem 1: Either your Remote Computer does not support your Local PC RDP Security setting or your Local PC does not accept your Remote Computer Security setting..

              - Problem 2: You've chose or select a wrong security setting for RDP Logins..
              Last edited by DewlanceWindowsVPS; 10th April 2012, 09:09.

              Comment


              • #8
                Re: RDP in Server 2008 R1 DOA Solved

                Originally posted by mpoertner View Post
                What I find interesting is you say that you rebuilt the server from scratch and the problem still persists. That would make me think its a group policy thing but why would a power failure cause that. Maybe some data corruption when the system went down?

                I had a problem like this, similar symptoms anyway. Even though the firewall said it was disabled it wasn't truly until I issued the following command:

                Netsh advfirewall set allprofiles state off

                You can turn it back on changing state off to state on.

                Worth a try?
                Thanks you put me on the right track. I'm embarrassed to admit that I had the remote desktop Firewall Scope settings back to front on the RDP rule as well as a Group policy setting wrong which I picked up through RSOP.

                How I found it was reverting the Firewall rules back to default and then seeing a strange IP Range in the scope column. I can't believe I screwed this up so badly.

                Thanks for everyone's suggestions including

                Comment


                • #9
                  Re: RDP in Server 2008 R1 DOA

                  If you stare at a picture long enough your eyes wont focus on the details... In the same way sometimes you just need a fresh pair of eyes to look at a problem. Nothing to be embarrassed about. Glad you got it fixed!

                  Comment

                  Working...
                  X