Announcement

Collapse
No announcement yet.

Printer logon script not running on Windows 7 pro machines.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Printer logon script not running on Windows 7 pro machines.

    Hi, I created 2 GPO's (both logon scripts: 1 for mapping network drives, the other for installing our network printers). When I log into Windows XP Pro machines, both scripts run fine. However, when I log into a Win 7 Pro machine, only the mapping drive script runs, the printer script does not. I turned off UAC and gave local admin rights but the script still doesn't run. Running the printer script manually does install the printers on the Win 7 machines but obviously I want to avoid doing this.

    Can anyone offer any insight?

    Thanks.

  • #2
    Re: Printer logon script not running on Windows 7 pro machines.

    Hi,

    Are you mapping the printers via a statupr vbs or with the group policy preferences ?

    Try disabling the point-and-click restrictions in your printer gpo ( both on user and computer settings ).

    These options are available in the Win7\2008R2 group policy admx templates, check if you have those on your \\%AD-DOMAIN%\SYSVOL\%AD-DOMAIN%\Policies\PolicyDefinitions

    If you dont have it, download from MS or copy them from a Win7\2008r2 host to the above path.

    The tree structure will be:

    dir \Policies\PolicyDefinitions:
    06/09/2011 11:23 <DIR> en-us
    06/09/2011 11:23 <DIR> it-it
    01/10/2010 06:54 111.924 access14.admx
    06/07/2010 15:05 4.717 ActiveXInstallService.admx
    06/07/2010 15:05 4.714 AddRemovePrograms.admx
    06/07/2010 15:06 1.249 adfs.admx
    06/07/2010 15:05 5.393 AppCompat.admx
    06/07/2010 15:04 5.965 AttachmentManager.admx
    06/07/2010 15:05 3.391 AutoPlay.admx
    ...

    btw,

    http://technet.microsoft.com/en-us/l.../cc753269.aspx

    http://social.technet.microsoft.com/...b-c45cb0583298

    Let us know if this solve your problem.

    Bye


    Tano

    Comment

    Working...
    X