Announcement

Collapse
No announcement yet.

FTP Windows server 2008 R2 problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • FTP Windows server 2008 R2 problem

    Hello there! I am new, and this is my second post, so please be gentle

    I have setup a FTP-server in Windows Server 2008 R2.

    I have a Directory called FTP Root
    In that directory I have a directory called drop

    The point with this ftp-server is that people should have the rights to upload documents to the drop-directory, but NOT have the rights to actually see the content.

    THAT actually works when I use File Zilla FTP Client.

    BUT not when I use explorer local computer (either my own, or local on the server), I get 550 error.

    I have turned OFF Windows firewall completely, but it doesn't quite do it.

    I also can't find any good howtos on this particular subject yet.

    Any ideas? I suspect that this might have something to do with active / passive, but I don't know.

  • #2
    Re: FTP Windows server 2008 R2 problem

    When you say "explorer", do you mean Internet Explorer aimed at the FTP site, or Windows Explorer pointed at the drop directory? Based on the error you're getting, I would assume IE.
    Gareth Howells

    BSc (Hons), MBCS, MCP, MCDST, ICCE

    Any advice is given in good faith and without warranty.

    Please give reputation points if somebody has helped you.

    "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

    "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.

    Comment


    • #3
      Re: FTP Windows server 2008 R2 problem

      Originally posted by gforceindustries View Post
      When you say "explorer", do you mean Internet Explorer aimed at the FTP site, or Windows Explorer pointed at the drop directory? Based on the error you're getting, I would assume IE.
      Hello!

      When I mean explorer, i ordinarily mean explorer. But in this case, I also mean Internet Explorer.

      So, both. Get no connection error. BUT, if I use FileZilla it magically works.

      Comment


      • #4
        Re: FTP Windows server 2008 R2 problem

        Not sure about IE.

        Regarding accessing the folder through Windows Explorer, enable Access Based Enumeration on the share. That will prevent users from seeing files listed that they don't have permission to access.
        Gareth Howells

        BSc (Hons), MBCS, MCP, MCDST, ICCE

        Any advice is given in good faith and without warranty.

        Please give reputation points if somebody has helped you.

        "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

        "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.

        Comment


        • #5
          Re: FTP Windows server 2008 R2 problem

          Originally posted by gforceindustries View Post
          enable Access Based Enumeration on the
          Access based enumeration is already active on the server. without any luck

          Comment


          • #6
            Re: FTP Windows server 2008 R2 problem

            Another thing I'd suggest is for you to install a dedicated FTP Server program such as Blackmoon FTP Server by Selom Ofori, WS_FTP Server by ipswitch, or Serv-U File Server by RhinoSoft. These applications have a lot more features than simply creating the server in Windows itself. I'm sure that these programs have the feature you're looking for.

            Comment


            • #7
              Re: FTP Windows server 2008 R2 problem

              Don't forget Mr Snuggles that IE and Explorer are NOT real FTP clients. Maybe the extra features in Filezilla allow this dropbox to work as intended.

              Have you tried it with FireFox and other Browsers to see if that works? If you are on a Domain you can use a GPO to push out Filezilla to the workstations.
              1 1 was a racehorse.
              2 2 was 1 2.
              1 1 1 1 race 1 day,
              2 2 1 1 2

              Comment


              • #8
                Re: FTP Windows server 2008 R2 problem

                I'd not recommend using Firefox as an alternate browser to connect to an FTP server. Firefox doesn't support the FTP protocol. One thing I would recommend though is for you to purchase Web Drive licenses for your workstations and then use that program. it allows you to map your server as a network drive through it's interface, and then it also includes backup and sync features that can help with backups, that way, you no longer need to access file shares through VPN or offline files while away from the network.

                Comment


                • #9
                  Re: FTP Windows server 2008 R2 problem

                  Hello,
                  here is how to do this.
                  Set Deny List /Read data security permission for the user allowed to log in and upload data. Make sure that the write permission exist.
                  I tested it and it is worked from command prompt and from IE also.

                  ftp> put
                  Local file c:/test.txt
                  Remote file /drop/text.txt
                  200 PORT command successful.
                  150 Opening ASCII mode data connection for /drop/text.txt.
                  226 Transfer complete.
                  ftp: 22 bytes sent in 0.16Seconds 0.14Kbytes/sec.
                  ftp> cd drop
                  250 CWD command successful.
                  ftp> dir
                  200 PORT command successful.
                  150 Opening ASCII mode data connection for /bin/ls.
                  550 .: Access is denied.
                  ftp>


                  Br,
                  Csaba
                  Attached Files
                  Last edited by netxt; 29th March 2011, 10:22.
                  Regards,
                  Csaba Papp
                  MCSA+messaging, MCSE, CCNA
                  ...............................
                  Remember to give credit where credit is due and leave reputation points where appropriate
                  .................................

                  Comment

                  Working...
                  X