No announcement yet.

SYSVOL and NETLOGON not replicating

  • Filter
  • Time
  • Show
Clear All
new posts

  • SYSVOL and NETLOGON not replicating

    One of our branch offices is not replicating the SYSVOL and NETLOGON directories. We have a total of 3 sites which are geographically remote locations; the main AD server at head office is running Windows Server 2008 and both branch offices are running Windows Server 2008 R2.

    We are getting this error at one of the sites:
    The File Replication Service has detected that the replica set "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)" is in JRNL_WRAP_ERROR.

    Replica set name is : "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)"
    Replica root path is : "c:\windows\sysvol\domain"
    Replica root volume is : "\\.\C:"
    A Replica set hits JRNL_WRAP_ERROR when the record that it is trying to read from the NTFS USN journal is not found. This can occur because of one of the following reasons.

    [1] Volume "\\.\C:" has been formatted.
    [2] The NTFS USN journal on volume "\\.\C:" has been deleted.
    [3] The NTFS USN journal on volume "\\.\C:" has been truncated. Chkdsk can truncate the journal if it finds corrupt entries at the end of the journal.
    [4] File Replication Service was not running on this computer for a long time.
    [5] File Replication Service could not keep up with the rate of Disk IO activity on "\\.\C:".
    Setting the "Enable Journal Wrap Automatic Restore" registry parameter to 1 will cause the following recovery steps to be taken to automatically recover from this error state.
    [1] At the first poll, which will occur in 5 minutes, this computer will be deleted from the replica set. If you do not want to wait 5 minutes, then run "net stop ntfrs" followed by "net start ntfrs" to restart the File Replication Service.
    [2] At the poll following the deletion this computer will be re-added to the replica set. The re-addition will trigger a full tree sync for the replica set.

    WARNING: During the recovery process data in the replica tree may be unavailable. You should reset the registry parameter described above to 0 to prevent automatic recovery from making the data unexpectedly unavailable if this error condition occurs again.

    To change this registry parameter, run regedit.

    Click on Start, Run and type regedit.

    Click down the key path:
    "System\CurrentControlSet\Services\NtFrs\Parameter s"
    Double click on the value name
    "Enable Journal Wrap Automatic Restore"
    and update the value.

    If the value name is not present you may add it with the New->DWORD Value function under the Edit Menu item. Type the value name exactly as shown above.
    What I don't understand is why there is only one branch office that isn't working while the other is.

    I've checked the registry key noted in the error log however it doesn't exist on any of the servers (including the working ones). What's your guys recommendations?

  • #2
    Re: SYSVOL and NETLOGON not replicating

    See if they help.
    Joined: 23rd December 2003
    Departed: 23rd December 2015


    • #3
      Re: SYSVOL and NETLOGON not replicating

      Thanks Biggles.

      I was worried because this AD controller was across the country. I've tried the registry addition that it suggested in the Event ID and it worked.

      For those of you who are leery as I was, once you add the registry key (I used the value of 1), it disables the SYSVOL and NETLOGON shares and renames the data within (but doesn't delete until a successful replication has occurred).


      • #4
        Re: SYSVOL and NETLOGON not replicating

        Thanks for the feedback and glad it work out for you.
        Joined: 23rd December 2003
        Departed: 23rd December 2015