Announcement

Collapse
No announcement yet.

https service (pre IIS) returning 400 - ("Bad request")

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • https service (pre IIS) returning 400 - ("Bad request")

    Hi people.

    We are experiencing a major issue on our IIS server.

    Applications are making HTTP requests to our server which by accident include a space (" ") e.g. GET /file.aspx?q=1 &x=2

    the problem is that the http.sys service is returning a 400 "Bad request" to the client and not even forwarding it to IIS. If this issue was occuring in the IIS Application i could handle it be a RewritePath Or RewriteUrl, but as i mentioned above, IIS is not receving this request.

    Please advice

    Thanks in advance.

    Eli
    Last edited by iandyou; 15th March 2011, 07:16.

  • #2
    Re: https service (pre IIS) returning 400 - ("Bad request&quot

    fix the application.
    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

    Comment


    • #3
      Re: https service (pre IIS) returning 400 - ("Bad request&quot

      Originally posted by tehcamel View Post
      fix the application.
      Hi, Thanks for your reply,
      But as i mentioned, 400 is returned by http.sys before application.

      Comment


      • #4
        Re: https service (pre IIS) returning 400 - ("Bad request&quot

        but the application is making the malformed request - you said so yourself.

        therefore, since the application is not correctrly interfacing with the protocol, fix the application.
        Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

        Comment

        Working...
        X