No announcement yet.

ADPrep errors (2008 R2)

  • Filter
  • Time
  • Show
Clear All
new posts

  • ADPrep errors (2008 R2)

    hi guys

    I am having a similar issue but cannot seem to get it resolved. I have attempted a few of the things that are in this post, (and various others) and I am at a loss on what to try. I have a windows 2003 domain with 3 server 2003 DCs and I am attempting to run dcpromo on my windows 2008 machine (already joined to the domain). I have ran adprep on the appropriate servers and still get the following error when running dcpromo:

    Active Directory Domain Services Installation Wizard:
    To install a domain controller into this Active Directory domain, you must first prepare the domain using "adprep /domainprep". The Adprep utility is available on the Windows Server 2008 R2 installation media in the \support\adprep folder.

    Any help would be appreciated. I have been searching for a solution on this for weeks now and I am at my wits end


  • #2
    Re: 2008 dcpromo into existing 2003 domain - continued adprep warning

    2008 or 2008 R2? Have you run adprep from a 2008 or 2008 R2 disk?

    You state 2008, but the error message you've quoted states 2008 R2.
    Gareth Howells

    BSc (Hons), MBCS, MCP, MCDST, ICCE

    Any advice is given in good faith and without warranty.

    Please give reputation points if somebody has helped you.

    "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

    "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.


    • #3
      Re: 2008 dcpromo into existing 2003 domain - continued adprep warning

      sorry, it is 2008 R2, and yes I have ran adprep from the 2008 R2 disc



      • #4
        Re: 2008 dcpromo into existing 2003 domain - continued adprep warning

        Split to new thread.

        Have you allowed time to replicate and have you checked the new schema version is correct (
        (My 2008R2 domain gives v47)

        Did you run ADPREP on the schema master FSMO holder?
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd

        ** Remember to give credit where credit is due and leave reputation points where appropriate **


        • #5
          Re: ADPrep errors (2008 R2)

          i upgraded my DC 2008 using this site.

          scroll down at least half way till you see the command with forest prep.

          Do the forest prep first, then the rodcprep, then the domain prep, should install with no problem. I'm pretty sure you have to point to support on all 3, not sources. i.e. d:\support\adprep\adprep /forestprep.hope this helps
          Last edited by Kobe 310; 13th March 2011, 22:28.


          • #6
            Re: ADPrep errors (2008 R2)

            thanks for everyone's help and input. It appears that I was not using the correct version of adprep, once I was able to find that it worked.

            thanks again!