No announcement yet.

Print Server x86 Blues

  • Filter
  • Time
  • Show
Clear All
new posts

  • Print Server x86 Blues

    I am in the process of standing up a brand new 2008 R2 Print Server. We are planning to deploy Shared Printers through Group Policy Preferences. The preferences work perfectly on a x64 Win 7 machine.

    However, we have an x86 Windows XP machine we are using to test and cannot get the printers to map. The majority of our environment is x86 XP. I know the GPO Preferences are applying because I am also mapping a couple of drives and placing an icon on the desktop.

    After viewing some of the logs, I found this error message:

    Event Type: Warning
    Event Source: Group Policy Printers
    Event Category: (2)
    Event ID: 4098
    Date: 1/18/2011
    Time: 8:12:46 AM
    Computer: MWXPDESK30
    The user 'printer name' preference item in the 'Test Loc GPO 2 {5CD0ED68-8E8C-4E3D-A881-40283238A53F}' Group Policy object did not apply because it failed with error code '0x8000ffff Catastrophic failure' This error was suppressed.

    For more information, see Help and Support Center at
    After some research, it came to be that this is related to not having the x86 drivers installed. Simple, right?

    Not exactly, I've spent several hours trying to get this to work to where the x86 drivers will automatically install for x86 machines. I've tried installing a Universal, PCL, and PS under the Sharing tab of the printer.

    I have tried installing additional printers under the Print Server role of the server. I always get an error message of this drive is not valid for the requested processor architecture.

    The only way I can successfully map the printer is if I manually map the printer and add the driver myself on the client.

    I've ever tried a different printer model and have the same issue. Both printers are Ricoh printers.

    I've searched all through Google and cannot find a reasonable solution.

    Anyone have suggestions?
    Last edited by boondock; 18th January 2011, 14:56.
    MCITP:SA, MCSA 2003, MCP, CCNA, A+, Net+, Security+

  • #2
    Re: Print Server x86 Blues

    Well, I did some additional digging and found out that if the driver is not named the EXACT same thing (case included), the installation will fail of the x86 driver.

    For instance, if the x64 driver is named "Really Cool Printer", the x86 cannot be named "Cool Printer". It has to be named "Really Cool Printer as well for the x86. Heck, it can't even be "REALLY Cool Printer", it must be the exact same name including case.

    To rename the driver, you must find the .inf file that is used for x86 driver setup when the download is extracted and open it in notepad.

    Then find the vendor name, in my case it was Ricoh. It will be denoted in brackets. Mine looked like [Ricoh]. It was the 3rd section down after the Version and Manufacturer sections.

    Under this, you will see the model of the printers. Edit this to where the name of of the model looks exactly like the x64 version. Then save in notepad. For example, mine said "RICOH Aficio MP C4000 PS", this is what I changed to match x64 driver name of "Ricoh Aficio MP C4000 PS". Noticed the difference in case of Ricoh.

    I was able to go directly to the sharing tab, click the x86, load the new driver.
    MCITP:SA, MCSA 2003, MCP, CCNA, A+, Net+, Security+


    • #3
      Re: Print Server x86 Blues

      Interesting findings....... : )
      Thanks & Regards

      MCTS 2008, MCTIP, MCSE 2003, MCSA+Messaging E2K3, MCP, E2K7
      Sr. Wintel Eng. (Investment Bank)
      Independent IT Consultant and Architect

      Show your appreciation for my help by giving reputation points