Announcement

Collapse
No announcement yet.

"Access Denied" through RDP

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Access Denied" through RDP

    Anyone seen this before ? Fresh install, only windows updates applied, no domain, nothing in the eventlog .. happened to me now on Server 2008 R1 SP2 and R2 ...


  • #2
    Re: "Access Denied" through RDP

    Have you set a password? One is needed for RDP access
    Who are you logging on as? Are they a member of the Remote Desktop Operators group (or whatever the actual name is)
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: "Access Denied" through RDP

      Originally posted by Ossian View Post
      Have you set a password? One is needed for RDP access
      Who are you logging on as? Are they a member of the Remote Desktop Operators group (or whatever the actual name is)
      This is a fresh install basically with no other user apart from "Administrator" .. so fresh install, enable Remote Desktop and go ..

      It seems to work for a while but once / twice a day, out of the blue, it popps up with that error where you have to reboot the server in order to get back in.

      Most google hits referring to server in the domain, but this isn't in a domain as it is a fresh server ...

      Comment


      • #4
        Re: "Access Denied" through RDP

        If it is a brand new build, I would seriously consider flattening it and starting again rather than troubleshooting it. Clearly something is wrong and it will probably become worse as time goes by
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd
        Scotland

        ** Remember to give credit where credit is due and leave reputation points where appropriate **

        Comment


        • #5
          Re: "Access Denied" through RDP

          Anything in the Event Logs? That is definitely a weird one... I have to agree with Ossian. If nothing's in the logs and Google searches are largely coming up short, I say rebuild it.

          Chris

          Comment


          • #6
            Re: "Access Denied" through RDP

            Found the answer...

            I have a 2008 R2 server that had this problem - i.e. Immediate "access denied" using RDP.

            This server had been moved between domains and some of the services including

            Remote Desktop Services

            &

            Distributed Transaction Coordinator (this seemed to slow the logon)

            had has their logon accounts reset from "Network Service" to "Local System". I reset the RDS service to "Network Service" (just put any valid password into the box) and its all working again.

            No idea why these changed - just happy to have fixed the problem

            Cheers

            Wt29

            Comment


            • #7
              Re: "Access Denied" through RDP

              Cheers for keeping us updated,
              One server in question was never in a domain and has been reinstalled since but I will certainly keep this in mind.

              The first server I saw was indeed a domain server, but was als reinstalled (or in that case reverted to a snapshot).

              But it does indeed sound like a promising solution


              Originally posted by wt29 View Post
              Found the answer...

              I have a 2008 R2 server that had this problem - i.e. Immediate "access denied" using RDP.

              This server had been moved between domains and some of the services including

              Remote Desktop Services

              &

              Distributed Transaction Coordinator (this seemed to slow the logon)

              had has their logon accounts reset from "Network Service" to "Local System". I reset the RDS service to "Network Service" (just put any valid password into the box) and its all working again.

              No idea why these changed - just happy to have fixed the problem

              Cheers

              Wt29

              Comment


              • #8
                Re: "Access Denied" through RDP

                Originally posted by Ossian View Post
                If it is a brand new build, I would seriously consider flattening it and starting again rather than troubleshooting it. Clearly something is wrong and it will probably become worse as time goes by
                I agree. If its a brand new build reinstall, patch, and try again.

                Comment

                Working...
                X