Announcement

Collapse
No announcement yet.

NAP agent properties greyed out

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • NAP agent properties greyed out

    I am getting this Error in the Windows Server 2008R2 in the Event logs

    Event ID 10016:

    The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID
    {24FF4FDC-1D9F-4195-8C79-0DA39248FF48}
    and APPID
    {B292921D-AF50-400C-9B75-0C57A7F29BA1}
    to the user NT AUTHORITY\SYSTEM SID (S-1-5-1 from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

    I have found the solution on Microsoft site but when I try to edit NAP Agent properties in DCOM it is greyed out, Hope to get the exact Solution for this Soon

  • #2
    Re: NAP agent properties greyed out

    NOT suitable for wall of fame forum
    Moved to Server 2008

    Could you enlighten us which solution you have tried so we don't keep pointing you to it
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: NAP agent properties greyed out

      The solution is -

      Grant the user permissions to start the COM component. To do this, follow these steps:
      1. Click Start, click Run, type regedit in the Open box, and then click OK.
      2. Locate and then click the following registry subkey: HKEY_CLASSES_ROOT\CLSID\CLSID value
      Note In this subkey, "CLSID value" is a placeholder for the CLSID information that appears in the message.
      3. In the right pane, double-click AppID.

      The Edit String dialog box appears. Leave this dialog box open and continue to the next step.
      4. Click Start, click Run, type dcomcnfg in the Open box, and then click OK.

      If a Windows Security Alert message prompts you to keep blocking the Microsoft Management Console program, click to unblock the program.
      5. In Component Services, double-click Component Services, double-click Computers, double-click My Computer, and then click DCOM Config.
      6. In the details pane, locate the program by using the friendly name.

      If the AppGUID identifier is listed instead of the friendly name, locate the program by using this identifier.
      7. Right-click the program, and then click Properties.
      8. Click the Security tab.
      9. In the Launch and Activation Permissions area, click Customize, and then click Edit.
      10. Click Add, type the user's account name, and then click OK.
      11. While the user is selected, click to select the Allow check boxes for the following items:
      o Local Launch
      o Remote Launch
      o Local Activation
      o Remote Activation
      12. Click OK two times.
      13. Quit Registry Editor.
      Grant the correct permissions to the Network Service account


      To grant the correct permissions to the Network Service account, follow these steps:
      1. Click Start, click Run, type dcomcnfg in the Open box, and then click OK.
      2. In Component Services, double-click Component Services, and then double-click Computers.
      3. Right-click My Computer, and then click Properties.
      4. Click the COM Security tab.
      5. In the Launch and Activation Permissions area, click Edit Default.
      6. Click Add, type Network Service, and then click OK.
      7. While Network Service is selected, click to select the Allow check boxes for the following items:
      o Local Launch
      o Remote Launch
      o Local Activation
      o Remote Activation
      Click OK two times

      Comment


      • #4
        Re: NAP agent properties greyed out

        I get this error on a WS2008R2 serever where I setup Sharepoint.

        The registry does NOT have the CLSID Value entry, though.

        Comment

        Working...
        X