Announcement

Collapse
No announcement yet.

Setup BITS foreground for WSUS Server 2008 R2

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Setup BITS foreground for WSUS Server 2008 R2

    Ok so I have tried and tried and tried but apparently I am neither trying hard enough nor am I trying in the right place. I can NOT set BITS to the foreground mode for WSUS. The download rates of 8k are just fine for normal operations but when I am downloading 1.5G of information for a first load, that just does not cut it. So given that it is a server 2008 R2 X64 server with WSUS SP 3 and BITS v4.0. How do I set it to foreground mode with a default (NON-SQL) database setup?

    If I can provide any more information let me know, this is making me completely insane.
    Two things:
    1) If I wrote something wrong please please please let me know. I want to know ESPECIALLY if I am wrong.
    2) I have a tendency to write things that are misconstrued as being agressive or not so pleasant. That is not my intent.

  • #2
    Re: Setup BITS foreground for WSUS Server 2008 R2

    Err why is this happening?
    I've done this only once when the proxy which was used didn't support http/1.1 well.
    Marcel
    Technical Consultant
    Netherlands
    http://www.phetios.com
    http://blog.nessus.nl

    MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
    "No matter how secure, there is always the human factor."

    "Enjoy life today, tomorrow may never come."
    "If you're going through hell, keep going. ~Winston Churchill"

    Comment


    • #3
      Re: Setup BITS foreground for WSUS Server 2008 R2

      Oh can of worms can of worms...

      Let me esplain... no wait, there is too much. Let me sum up.

      I set up wsus (or whatever the latest iteration of it is called) on a server 2k3 box about a year ago. It threw errors all over the place. Made a mess. I had to clean the carpet it was spewing so many errors. Anyway so I figured out that BITS was the issue and just set BITS to foreground and voila everything started working like a champ.

      Fast forward a year. We are virutalizing all of our servers (Why does the spell checker on here show virtualizing as misspelled?) anyway so I build a 2k8R2 X64 server and ... same errors, all over the place. On the walls on the ceiling, what a mess. So.... I set BITS to foreground mode and... no no wait that didn't work. Nor did anything else I have read. In complete frustration I made our firewall guy poke a hole in the firewall for this server and everything starts working... very.... very..... very.... slowly. So it still errors out, but its a different error now. It is my ASSUMPTION that setting BITS to foreground mode will rectify the error (and we can lock our hole down again) however I can not find a single explanation of HOW.

      Two things:
      1) If I wrote something wrong please please please let me know. I want to know ESPECIALLY if I am wrong.
      2) I have a tendency to write things that are misconstrued as being agressive or not so pleasant. That is not my intent.

      Comment


      • #4
        Re: Setup BITS foreground for WSUS Server 2008 R2

        Bits uses HTTP/1.1
        What are the errors your getting?
        What kind of firewall/proxy do you have in place?
        Marcel
        Technical Consultant
        Netherlands
        http://www.phetios.com
        http://blog.nessus.nl

        MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
        "No matter how secure, there is always the human factor."

        "Enjoy life today, tomorrow may never come."
        "If you're going through hell, keep going. ~Winston Churchill"

        Comment


        • #5
          Re: Setup BITS foreground for WSUS Server 2008 R2

          Bits uses HTTP/1.1

          Yes the problem specifically is the range protocol header which is getting stripped by our firewall.

          What are the errors your getting?

          error 364: Content file download failed. Reason: The connection with the server was terminated abnormally...

          error 10032: The server is failing to download some updates.


          What kind of firewall/proxy do you have in place?

          We have a Fortiguard firewall (which is passing everything unmolested in and out (yes this is a problem, thus I am trying to figure out how to get BITS set to foreground mode which does work with our firewall in place)) and no proxy.
          Two things:
          1) If I wrote something wrong please please please let me know. I want to know ESPECIALLY if I am wrong.
          2) I have a tendency to write things that are misconstrued as being agressive or not so pleasant. That is not my intent.

          Comment


          • #6
            Re: Setup BITS foreground for WSUS Server 2008 R2

            Personally I'm always preffer to modify the cause of the issue rather then finding a workaround.
            Not supporting (or not willing to support) the range protocol header of HTTP/1.1 is kinda weird... HTTP/1.1 is the default since 1997.
            If you configure it in foreground mode, it will use HTTP/1.0 and it will setup loads and loads of connnections...

            Anyhow I would request the firewall admin to change it...

            Or... what have you tried to get it in foreground mode?
            Marcel
            Technical Consultant
            Netherlands
            http://www.phetios.com
            http://blog.nessus.nl

            MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
            "No matter how secure, there is always the human factor."

            "Enjoy life today, tomorrow may never come."
            "If you're going through hell, keep going. ~Winston Churchill"

            Comment


            • #7
              Re: Setup BITS foreground for WSUS Server 2008 R2

              Ahh but you are absolutely correct. The firewall and switches are the only things not under my control so getting the other guy to fix them... well lets just say its a task on its own. He knows about the problem but is currently researching the issue..........

              Meanwhile back at the ranch! I still have no SUS

              So the first thing I did was to download and attempt to install the WSUSDebugTool which failed miserably since I did not read the docs on it which state that it is not supported on Server 2008. My fault!

              Then I tried this command;

              %programfiles%\Update Services\tools\osql\osql.exe" -S Server\WSUS -E -b -n -Q "USE SUSDB update tbConfigurationC set BitsDownloadPriorityForeground=1

              Which also failed miserably (I am pretty much a know nothing when it comes to SQL). Since we do not have a SQL database and it is the lowly SQL express (or
              whatever it is called now). Again, my fault.

              Then I tried this command:

              C:\Program Files\Update Services\Tools>osql.exe -S typeinyourservernamehere\MICROSOFT##SSEE -E -b -n -Q "USE SUSDB update tbConfigurationC set BitsDownloadPriorityForeground=1

              Which as far as I can tell, did absolutely nothing.

              Thus in lieu of temper tantrums, alcohol binges or anything else completely destructive and not so useful, I came here looking for answers to life's problems. Or maybe just this problem.
              Two things:
              1) If I wrote something wrong please please please let me know. I want to know ESPECIALLY if I am wrong.
              2) I have a tendency to write things that are misconstrued as being agressive or not so pleasant. That is not my intent.

              Comment


              • #8
                Re: Setup BITS foreground for WSUS Server 2008 R2

                Did you see this one?
                http://social.technet.microsoft.com/...2-cf6b0991961b
                Marcel
                Technical Consultant
                Netherlands
                http://www.phetios.com
                http://blog.nessus.nl

                MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
                "No matter how secure, there is always the human factor."

                "Enjoy life today, tomorrow may never come."
                "If you're going through hell, keep going. ~Winston Churchill"

                Comment


                • #9
                  Re: Setup BITS foreground for WSUS Server 2008 R2

                  The only thing here that I have not seen is the Windows Firewall. So I disabled the firewall on the server and hopefully that will fix the problem. Downloading "a little bit at a time" is not really an answer. I am sure it is for Mr. Gavin (and hopefully it is for a bunch of you guys) however that is not an option for us here. I will let you know if it works or not.

                  Thanks for the help!
                  Two things:
                  1) If I wrote something wrong please please please let me know. I want to know ESPECIALLY if I am wrong.
                  2) I have a tendency to write things that are misconstrued as being agressive or not so pleasant. That is not my intent.

                  Comment


                  • #10
                    Re: Setup BITS foreground for WSUS Server 2008 R2

                    No I meant

                    Increase download speed in WSUS 3.0
                    My WSUS 3.0 server constantly got transfer rates between 10 and 30 kB/s. I searched for a solution to control the download speed, but I couldn't find any way to configure the WSUS download behaviour.

                    Finally I found out that I only needed to set BITS in foreground mode. In WSUS 2.0 this could be realized by downloading the WSUS debug Utility and the command "wsusdebugtool.exe /tool:setforegrounddownload ". Unfortunately the debug tool doesn't work with WSUS 3.0.

                    But luckily I found another problem solution at KB922330

                    If you are using WSUS 3.0 with a Windows Internal Database that was created by a default WSUS installation, type the following command:

                    "%programfiles%\Update Services\Setup\ExecuteSQL.exe" -S %Computername%\MICROSOFT##SSEE -d "SUSDB" -Q "update tbConfigurationC set BitsDownloadPriorityForeground=1"
                    If you configured WSUS 3.0 to use an existing installation of SQL Server, type the following command:

                    "%programfiles%\Update Services\Setup\ExecuteSQL.exe" -S %Computername% -d "SUSDB" -Q "update tbConfigurationC set BitsDownloadPriorityForeground=1"
                    Now restart the Update Services service and your WSUS 3.0 will leech at full speed.
                    Marcel
                    Technical Consultant
                    Netherlands
                    http://www.phetios.com
                    http://blog.nessus.nl

                    MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
                    "No matter how secure, there is always the human factor."

                    "Enjoy life today, tomorrow may never come."
                    "If you're going through hell, keep going. ~Winston Churchill"

                    Comment


                    • #11
                      Re: Setup BITS foreground for WSUS Server 2008 R2

                      Assuming this is what you are talking about:

                      "%programfiles%\Update Services\Setup\ExecuteSQL.exe" -S %Computername% -d "SUSDB" -Q "update tbConfigurationC set BitsDownloadPriorityForeground=1"

                      I THINK I already tried that one too, but I plugged it in again anyway in hopes that I missed it.

                      BTW Thanks for the help Dumber. It is appreciated.
                      Two things:
                      1) If I wrote something wrong please please please let me know. I want to know ESPECIALLY if I am wrong.
                      2) I have a tendency to write things that are misconstrued as being agressive or not so pleasant. That is not my intent.

                      Comment

                      Working...
                      X