No announcement yet.

DFS: Server 2008 mode grayed, req's met

  • Filter
  • Time
  • Show
Clear All
new posts

  • DFS: Server 2008 mode grayed, req's met

    I have a new forest with 5 domains total.
    All 5 domain controllers are Server 2008 R2.
    Forest and domain functional levels are all set to Server 2008 (not server 2008 R2).

    I have an another Server 2008 R2 server that is a member of one of the 5 domains, which I am trying to setup DFS namespace.

    When I am going through the "add role" wizard, I get to the select type of namespace question. I choose the Domain-based namespace radio button, but I cannot check the "Enable Windows Server 2008 mode" box, as it is grayed out.

    I have been digging everywhere and found that I meet the requirements to enable that mode, so why can't I enable it? What could I be missing?

    Here is an excerpt from technet listing the requirements:

    "To use the Windows Server 2008 mode, the domain and domain-based namespace must meet the following minimum requirements:

    The forest uses the Windows Server 2003 or higher forest functional level.

    The domain uses the Windows Server 2008 or higher domain functional level.

    All namespace servers are running Windows Server 2008."

    as stated before, my forest and domains are all server 2008 functional level
    and with regard to the last requirement, I have no existing namespaces, this is the first one.

    I appreciate any help. I have spent a lot of time searching on this, but have only found cases where people have run into this because of improper domain functional levels or existing namespaces that aren't server 2008.


  • #2
    Re: DFS: Server 2008 mode grayed, req's met

    Well, I found a workaround. So hopefully this post will help somebody.

    Originally when I was trying to setup this new namespace, I was doing so during the "add role" wizard for DFS. i.e. I chose the option to create the namespace during the wizard.

    what worked:
    Select the option to create the namespace later, let DFS role add succeed, reboot. Then create a new namespace from the DFS Management console. THIS method, the server 2008 mode option was not grayed fact it was selected by default. go figure.

    I am not sure why the option isn't available during the DFS add role wizard, but at least this method worked.


    • #3
      Re: DFS: Server 2008 mode grayed, req's met

      Thanks, it helped.

      Had the exact same problem with Windows Server 2008 R2, and it was resolved per your instructions.

      - Lars, Denmark.