No announcement yet.

Cannot write to SYSVOL folder remotely after restore

  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot write to SYSVOL folder remotely after restore

    Long story short a old backup was restored to a secondary drive on a domain controller to recover some files that were deleted. It appears the restored backup had system state information that updated some AD things to the D drive (where the backup was recovered) and not to the C drive like it should have been. After getting the required files the backup was deleted which deleted the SYSVOL folder which then replicated across the domain.

    So another restore from the night before that had a system state backup was done on another DC and restored everything back to normal EXCEPT we cannot remotely edit or write to the SYSVOL folder. All the files are there and correct, the domain and all users are good, everything has been working fine except for this issue. Now if I log into any of the domain controllers I can edit the files in the sysvol folder directly from that DC. I jsut cant browse to \\Server\Netlogon and edit anything. Permissions look fine but as a just in case I ran the procedure to reapply premissions to SYSVOL ( When I ran this I got a error:

    ----Configure File Security...
    Configure c:\windows\sysvol\sysvol.
    Warning 2: The system cannot find the file specified.
    Error setting security on c:\windows\sysvol\sysvol\domain.

    I double checked and c:\Windows\SYSVOL\sysvol\ has a single entry which is a link to MyDomain.local and when clicked goes to C:\Windows\SYSVOL\sysvol\MyDomain.local and does contain my Policies, scripts, and StarterGPOs folders (whcih is a copy of c:\Windows\SYSVOL\domain).

    Again everything looks fine and is running but if I browse to any DC's NETLogon directory or even just to \\MyDomain.local\NetLogon I cannot create or edit any files.

    Anything else I can do? 3 of the DC's are Server 2008 R2, one is Server 2003 R2. All have the same issue.