Announcement

Collapse
No announcement yet.

Idle network drive disconnects when idle.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Idle network drive disconnects when idle.

    Hi,

    I'm having a problem.

    Users network drives are being disconnected when PC stays idle too long (like during lunch). We have 2 servers (Win2k and Win2k8 STD(not R2)) right now and the problem happens with the network drive on only one of them (Win2k8 ).

    I've tried the NET CONFIG SERVER /autodisconnect:-1 setting along with the 65535 setting and still no luck. Changed the logon script to add /PERSISTENT:YES and still the same problem.

    Any idea would be appreciated hehe

    Regards,

    trep
    Last edited by biggles77; 2nd April 2010, 01:53. Reason: Fix smilie issue

  • #2
    Re: Idle network drive disconnects when idle.

    Is this what you have tried? http://support.microsoft.com/kb/308582
    Was it run on the Server or the Workstation?
    11 was a racehorse.
    22 was 12
    1111 race 1 day
    22112


    ************************************************** * ************************************************** ***********
    ** Remember to give credit where credit is due and click the LIKE option in the bottom right corner **
    ************************************************** ************************************************** ****** * *****

    Comment


    • #3
      Re: Idle network drive disconnects when idle.

      Do they just show as disconnected (red cross over drive) and reconnect automatically when clicked?
      If so, is it a major issue?
      Tom Jones
      MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
      PhD, MSc, FIAP, MIITT
      IT Trainer / Consultant
      Ossian Ltd
      Scotland

      ** Remember to give credit where credit is due and leave reputation points where appropriate **

      Comment


      • #4
        Re: Idle network drive disconnects when idle.

        This is what i've tried server side:

        http://support.microsoft.com/kb/297684

        There's an application using the network drive. When it disconnects, the application crashes. When i click on the disconnected network drive, it reconnects itself. It's not mission critical but it's quite annoying hehe

        Comment


        • #5
          Re: Idle network drive disconnects when idle.

          Originally posted by biggles77 View Post
          Is this what you have tried? http://support.microsoft.com/kb/308582
          Mmmmm, where did that come from? It was actually the same KB article you have in the above post that I was refering to.
          11 was a racehorse.
          22 was 12
          1111 race 1 day
          22112


          ************************************************** * ************************************************** ***********
          ** Remember to give credit where credit is due and click the LIKE option in the bottom right corner **
          ************************************************** ************************************************** ****** * *****

          Comment


          • #6
            Re: Idle network drive disconnects when idle.

            You might research this registry edit.

            HKLM\SYSTEM\CurrentControlSet\Services\LanmanServe r\Parameters

            DWord Hex
            "autodisconnect"=ffffffff

            .

            Comment


            • #7
              Re: Idle network drive disconnects when idle.

              Originally posted by trep View Post
              This is what i've tried server side:

              http://support.microsoft.com/kb/297684

              There's an application using the network drive. When it disconnects, the application crashes. When i click on the disconnected network drive, it reconnects itself. It's not mission critical but it's quite annoying hehe
              Check the Registry settings on the Workstation and modify them. That fixed the disconnect problem I experienced. (Have you converted the ffffffff into Decimal to see how long the disconnect time is? Interesting. )
              11 was a racehorse.
              22 was 12
              1111 race 1 day
              22112


              ************************************************** * ************************************************** ***********
              ** Remember to give credit where credit is due and click the LIKE option in the bottom right corner **
              ************************************************** ************************************************** ****** * *****

              Comment


              • #8
                Re: Idle network drive disconnects when idle.

                I'll try this. Server side, the registry key was set to ffff. I mapped network drive on the server to see if they would get disconnected as well and they did even with the registry key. I'll plan a reboot and still apply the parameter to the workstations and see how it goes.

                Thanks !

                Comment


                • #9
                  Re: Idle network drive disconnects when idle.

                  Well, problem is still there. XP and Vista machine are still experiencing it. Some machine who don't even have the autodisconnect parameter set are fine as well... However i've mapped network drives on a 2008 server and 2000 server to see if the problem would occur and it did not

                  Comment


                  • #10
                    Re: Idle network drive disconnects when idle.

                    Trep,

                    I have been having the same issue and I think I found a solution. Look in the power managment options for your ethernet cards and or adapters to make sure they are set for performance mode or never to allow for power save modes. Let me know Thanks

                    Comment


                    • #11
                      Re: Idle network drive disconnects when idle.

                      Hi,

                      I actually did that server side and the problem is still present. I need to look on the clients too, but i think it's weird since it didn't do that before... hehe

                      thanks !

                      Comment


                      • #12
                        Re: Idle network drive disconnects when idle.

                        Hi,

                        I'm bringing this thread back from the dead since I have an update on this.

                        I let one of the PC out of the domain to see if some policies could be the cause. While in Workgroup, i mapped the share manually and authenticated myself on the domain. It's been 4 days now and the mapping is still there.

                        Tried the same thing while the PC was joined to the domain. I mapped manually the shares and after a day, mapping was disconnected.

                        There aren't any fishy policies on the Domain. I even isolated the user account from any inheritence. While typing this, I'm thinking about doing the same with the computer account, let's see how it goes.

                        If someone has any idea on this, i'm open hehe

                        trep

                        Comment


                        • #13
                          Re: Idle network drive disconnects when idle.

                          Well, to conclude the testing, disconnection appears only when a domain user is logged on. If i login a local user and map network ressource (provifing a domain user/pass), there's no problem. I also made sure to block any policies for the user/computer on the domain...

                          Comment

                          Working...
                          X