Announcement

Collapse
No announcement yet.

WDS on Server 2008 ignoring answerfiles

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • WDS on Server 2008 ignoring answerfiles

    Hi everyone,

    this is my first post here, so I'm not sure if this is the right category. Anyway, here is a description of my problem:

    I recently installed the WDS Server Role on a Windows Server 2008 machine, which is not a Domain Controller. I configured it without changing the default settings, but skipped the Image Add wizard.
    I used the boot.wim from the Windows 7 x86 DVD as a boot image, and also created a Capture Image from it, using the wizard.
    The images I use are all Windows 7 Enterprise two generic ones, taken straight from the DVD (one x86 and one x64), and three custom images, created from a fresh install to which I added my necessary programs, and captured with the Capture Image mentioned earlier.
    I added those to three Image Install Groups. I also backed them up, and created for each of them a catalogue file with WSIM.
    Using the catalogue files, I created for each image an answerfile, and also one for the WDS client (using the catalogue of the generic x86 image). I set them up using the WDS GUI, through the properties of each image, and the properties of the server (placed it in the WDS Server folder, since it would accept files only from there). I put it under x86 architecture, assuming that it means the architecture of the boot image (found no material on that on the web).
    Here is the answerfile I created for the client:

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
    <settings pass="windowsPE">
    <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlnssi="http://www.w3.org/2001/XMLSchema-instance">
    <SetupUILanguage>
    <UILanguage>en-US</UILanguage>
    </SetupUILanguage>
    <InputLocale>en-US</InputLocale>
    </component>
    <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlnssi="http://www.w3.org/2001/XMLSchema-instance">
    <DiskConfiguration>
    <Disk wcm:action="add">
    <CreatePartitions>
    <CreatePartition wcm:action="add">
    <Order>1</Order>
    <Size>200</Size>
    <Type>Primary</Type>
    </CreatePartition>
    <CreatePartition wcm:action="add">
    <Order>2</Order>
    <Extend>true</Extend>
    <Type>Primary</Type>
    </CreatePartition>
    </CreatePartitions>
    <ModifyPartitions>
    <ModifyPartition wcm:action="add">
    <Format>NTFS</Format>
    <Order>1</Order>
    <PartitionID>1</PartitionID>
    <Label></Label>
    <Active>true</Active>
    </ModifyPartition>
    <ModifyPartition wcm:action="add">
    <PartitionID>2</PartitionID>
    <Order>2</Order>
    <Extend>true</Extend>
    <Format>NTFS</Format>
    </ModifyPartition>
    </ModifyPartitions>
    <DiskID>0</DiskID>
    <WillWipeDisk>true</WillWipeDisk>
    </Disk>
    <WillShowUI>OnError</WillShowUI>
    </DiskConfiguration>
    <ImageInstall>
    <OSImage>
    <InstallTo>
    <DiskID>0</DiskID>
    <PartitionID>2</PartitionID>
    </InstallTo>
    </OSImage>
    </ImageInstall>
    </component>
    </settings>
    <cpifflineImage cpi:source="wim:c:/wds%20backup/wdsimagesbackup/windows%207%20x86/win7x86.wim#Windows 7 ENTERPRISE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>

    Here are the problems:

    1. It ignores the answerfile for the client, and still asks me to which partition to install, and I have to format it myself, too. When I intentionally add a messed up line into it, I do get an error message. Also, I noted, it doesnt create a copy in the WDSClientUnattend folder, even though I have come to understand it is supposed to?
    2. For some of the custom images, I get an error message during the installation, claiming it cant parse the answerfile, on pass Specialize, component Microsoft Windows Shell Setup.
    No matter what I set in that component, I get that message, even if I leave it empty except for manually rewriting default settings.

    Today I installed Windows Server 2008R2 on the server, and went through the whole process again (though using the same images and answerfiles). I have the same problem.

    Id appreciate any thought or idea on the matter. Thank you very much.

  • #2
    Re: WDS on Server 2008 ignoring answerfiles

    I'm running it on Server 2003 R2, but I had bother with that section too installing 7 Enterprise. Below is my WDSClientUnattend.xml. Mine works OK (apart from the language settings, still working on that one!). This series of articles were a big help to me.

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
    <settings pass="windowsPE">
    <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlnssi="http://www.w3.org/2001/XMLSchema-instance">
    <SetupUILanguage>
    <UILanguage>0809:00000809</UILanguage>
    </SetupUILanguage>
    <InputLocale>0809:00000809</InputLocale>
    <SystemLocale>0809:00000809</SystemLocale>
    <UILanguage>0809:00000809</UILanguage>
    <UserLocale>0809:00000809</UserLocale>
    </component>
    <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlnssi="http://www.w3.org/2001/XMLSchema-instance">
    <DiskConfiguration>
    <Disk wcm:action="add">
    <CreatePartitions>
    <CreatePartition wcm:action="add">
    <Extend>true</Extend>
    <Order>1</Order>
    <Type>Primary</Type>
    </CreatePartition>
    </CreatePartitions>
    <ModifyPartitions>
    <ModifyPartition wcm:action="add">
    <Active>true</Active>
    <Extend>false</Extend>
    <Format>NTFS</Format>
    <Label>system</Label>
    <Letter>C</Letter>
    <Order>1</Order>
    <PartitionID>1</PartitionID>
    </ModifyPartition>
    </ModifyPartitions>
    <DiskID>0</DiskID>
    <WillWipeDisk>true</WillWipeDisk>
    </Disk>
    <WillShowUI>OnError</WillShowUI>
    </DiskConfiguration>
    <ImageInstall>
    <OSImage>
    <InstallTo>
    <DiskID>0</DiskID>
    <PartitionID>1</PartitionID>
    </InstallTo>
    </OSImage>
    </ImageInstall>
    <WindowsDeploymentServices>
    <ImageSelection>
    <InstallImage>
    <Filename>install.wim</Filename>
    <ImageGroup>Windows 7</ImageGroup>
    <ImageName>Windows 7 ENTERPRISE</ImageName>
    </InstallImage>
    <InstallTo>
    <DiskID>0</DiskID>
    <PartitionID>1</PartitionID>
    </InstallTo>
    </ImageSelection>
    <Login>
    <Credentials>
    <Domain></Domain>
    <Password></Password>
    <Username></Username>
    </Credentials>
    </Login>
    </WindowsDeploymentServices>
    </component>
    </settings>
    <cpifflineImage cpi:source="wim:d:/sources/install.wim#Windows 7 ENTERPRISE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>
    BSc, MCSA: Server 2008, MCSE, MCSA: Messaging, MCTS
    sigpic
    Cruachan's Blog

    Comment


    • #3
      Re: WDS on Server 2008 ignoring answerfiles

      Thank you very much, I will read the articles and try out your answer file!

      UPDATE:

      I followed the guide cruachan linked, and sadly, it did not work. Then, examining the answer file I noticed a setting which was not mentioned in the article:

      Microsoft-Windows-Setup/WindowsDeploymentServices/

      It has the InstallTo setting as well, and actually accepts it.

      That solved the first problem - except for the language selection screen. I understand that this is a known bug?

      As for the second problem, I'll check it again, write it up and post it here later. Thanks for the help!!
      Last edited by Ron F; 28th January 2010, 11:56.

      Comment


      • #4
        Re: WDS on Server 2008 ignoring answerfiles

        NP, I followed that guide and it didn't work for me, but that file I posted is actually for a Vista Business Image which I manually edited for Windows 7.

        Regarding the language thing, I got a suggestion that time zone is a required setting. I had mine set to GMT Standard Time but I noticed today that Windows 7 lists the London/Edinburgh/Dublin Time Zone as UTC rather than GMT, so I'll give that a go when I get a chance. Currently I'm using WDSClientUnattend.xml only and manually doing the OOBE wizard.
        BSc, MCSA: Server 2008, MCSE, MCSA: Messaging, MCTS
        sigpic
        Cruachan's Blog

        Comment

        Working...
        X