Announcement

Collapse
No announcement yet.

Security database on the server does not....

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Security database on the server does not....

    We have a member 2008 server that runs SQL 2005 that is giving us this error message: "The security database on the server does not have a computer account for this workstation trust relationship". We cannot log in with our domain accounts, only the local accounts. Nothing obvious in the event logs and to resolve it, we need to re-add it to our Windows 2003 domain. It will add successfully and then drop a few days latter. This is the only virtual 2008 server we have this problem with. Any ideas or suggestions?

  • #2
    Re: Security database on the server does not....

    that's very interesting that you add it, then it disappears a few days later.

    try protecting the object from deletion for a start.
    maybe audit the object, see if it's being deleted by someone ?

    Also - once you get the "no trust account" message, have you gone and checked in AD users and computers to see if the account really is missing ?
    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

    Comment


    • #3
      Re: Security database on the server does not....

      Yep, it's really missing. Checked all the DC's in case I was losing my mind. I searched, too, incase it was buried somewhere unexpected. I've never seen this before. Once I readded it, I checked the properties in adsiedit and everything looked normal. DNS is exactly as it should be...the strange part is that the machine has been up since June 09 and just started this behavior last week.

      Comment


      • #4
        Re: Security database on the server does not....

        no changes made to anything ?

        could be worth a PSS case..
        but to start with - try auditing..
        Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

        Comment


        • #5
          Re: Security database on the server does not....

          audit logs don't indicate anything obvious and this is just a backend for a casually used SQL database. It may get connected to once or twice a week. The DBA's swear they haven't logged into this server, except the SQL, and the admin says they haven't touched it since last month....but who knows? Isn't "nobody" the number one culprit when things break?

          So far the audit logs look fine and maybe it was just a fluke.

          Comment

          Working...
          X