Announcement

Collapse
No announcement yet.

Windows Deployment Services

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows Deployment Services

    I'm trying to automate WDS UI screen. What i want to do is following:

    - Select locale (Finnish)
    - Ask credentials (fill all fields automatically except password)
    - Ask what image to install
    - Wipe disk and create only one partition (c-drive) and install chosen image there

    I taked sample from Microsoft and modified it, but something went wrong. WDS shows error (Error on the unattend.xml).

    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="windowsPE">
            <component name="Microsoft-Windows-Setup" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="x86">
                <WindowsDeploymentServices>
                    <Login>
                        <WillShowUI>True</WillShowUI>
                        <Credentials>
                            <Username>Administrator</Username>
                            <Domain>Domain</Domain>
                        </Credentials>
                    </Login>
                    <ImageSelection>
                        <WillShowUI>OnError</WillShowUI>
                        <InstallTo>
                            <DiskID>0</DiskID>
                            <PartitionID>1</PartitionID>
                        </InstallTo>
                    </ImageSelection>
                </WindowsDeploymentServices>
                <DiskConfiguration>
                    <WillShowUI>OnError</WillShowUI>
                    <Disk>
                        <DiskID>0</DiskID>
                        <WillWipeDisk>true</WillWipeDisk>
                        <ModifyPartitions>
                            <ModifyPartition>
                                <Order>1</Order>
                                <PartitionID>1</PartitionID>
                                <Letter>C</Letter>
                                <Label>SYSTEM</Label>
                                <Format>NTFS</Format>
                                <Active>true</Active>
                                <Extend>false</Extend>
                            </ModifyPartition>
                        </ModifyPartitions>
                    </Disk>
                </DiskConfiguration>
            </component>
            <component name="Microsoft-Windows-International-Core-WinPE" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" processorArchitecture="x86">
                <SetupUILanguage>
                    <WillShowUI>OnError</WillShowUI>
                    <UILanguage>fi-FI</UILanguage>
                </SetupUILanguage>
                <UILanguage>fi-FI</UILanguage>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>
Working...
X