No announcement yet.

WSUS won't syncronise

  • Filter
  • Time
  • Show
Clear All
new posts

  • WSUS won't syncronise

    So, I have a windows 2008 server, using a VLK.
    i installed Update Services on it, and for the first 4 syncs, it synced fine.
    It hasn't synced since.

    This is the output of the error:

    WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: An attempt was made to access a socket in a way forbidden by its access permissions
    at System.Net.HttpWebRequest.GetRequestStream()
    at System.Web.Services.Protocols.SoapHttpClientProtoc ol.Invoke(String methodName, Object[] parameters)
    at Microsoft.UpdateServices.ServerSyncWebServices.Ser verSync.ServerSyncProxy.GetAuthConfig()
    at Microsoft.UpdateServices.ServerSync.ServerSyncLib. InternetGetServerAuthConfig(ServerSyncProxy proxy, WebServiceCommunicationHelper webServiceHelper)
    at Microsoft.UpdateServices.ServerSync.ServerSyncLib. Authenticate(AuthorizationManager authorizationManager, Boolean checkExpiration, ServerSyncProxy proxy, Cookie cookie, WebServiceCommunicationHelper webServiceHelper)
    at Microsoft.UpdateServices.ServerSync.CatalogSyncAge ntCore.SyncConfigUpdatesFromUSS()
    at Microsoft.UpdateServices.ServerSync.CatalogSyncAge ntCore.ExecuteSyncProtocol(Boolean allowRedirect)
    It looks like it's blathering on about authentication and cookies and proxies.. but I definitely don't have a proxy configured, and nothing else installed on the server.

    I'm wondering if it might have something to do with IE Enhanced Security Configuration or something, and trusted sites.. any ideas ?
    Please do show your appreciation to those who assist you by leaving Rep Point

  • #2
    Re: WSUS won't syncronise

    got it..

    Name Group Profile Enabled Action Program Local Address Remote Address Protocol Local Port Remote Port Allowed Computers
    AllowWSUS Any Yes Allow %ProgramFiles%\Update Services\service\bin\wsusservice.exe Any Any TCP Any 80, 443 Any

    When i installed vmware server, I think i may have changed the network profile for my only network card.. resulting in outbound access being blocked.

    I added a firewall entry on a hunch, allowing application wsusservice.exe outbounc tcp access to ports 80 and 443.. and now.. go go syncronisation
    Please do show your appreciation to those who assist you by leaving Rep Point