Announcement

Collapse
No announcement yet.

iis can't run smoothly

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • iis can't run smoothly

    i am using windows2003 and test running IIS webserver for company, by using a public IP. and it's work properly, what the problem is, when i try to access the web site in internet, the web browser always ask to enter the username and password. i have try to solve that problem by restart the service and it's running properly again but not for long time , 1 and 2 days later it's require the username and password again even run in the local computer.
    anymore know the real mistack . please give some advise to me! thank

  • #2
    Re: iis can't run smoothly

    Hi
    Have you checked the "Authentication and Access Control" on the web site you are facing the problems?(right click web-site and then Directory security tab).
    Mabye you want only anonymous aythentication to be checked, if this is a public site.

    Comment


    • #3
      Re: iis can't run smoothly

      thank for your reply, and yes, i have checked for what you mentioned, and the configuration is right. but the web site still require the username and password to be browsed. i think it's possible that my iis service have been control by virus or not? and maybe the iis sercice need to be reinstall? or even reinstall the windows?

      Comment


      • #4
        Re: iis can't run smoothly

        Can you post a screen shot of the page you checked Authentication and Access Control.
        1 1 was a racehorse.
        2 2 was 1 2.
        1 1 1 1 race 1 day,
        2 2 1 1 2

        Comment


        • #5
          Re: iis can't run smoothly

          thank for your reply, and here is what i have screen shoot from my IIS,

          Click image for larger version

Name:	Authentication.JPG
Views:	1
Size:	37.3 KB
ID:	462603

          Click image for larger version

Name:	IP address.JPG
Views:	1
Size:	21.3 KB
ID:	462604

          Comment


          • #6
            Re: iis can't run smoothly

            I see you have checked "integrated authentication".
            If this is a public site I don' t think you need this.

            Comment


            • #7
              Re: iis can't run smoothly

              ok, i have tried for you said ,but when i uncheck it, my web site can't working, it display text as below
              "You are not authorized to view this page
              You do not have permission to view this directory or page using the credentials that you supplied. "
              but when i recheck it , my web site require username and password back.

              Comment


              • #8
                Re: iis can't run smoothly

                Does IUSR_SERVER1 have permissions to access the folders that the website is contained in?
                1 1 was a racehorse.
                2 2 was 1 2.
                1 1 1 1 race 1 day,
                2 2 1 1 2

                Comment


                • #9
                  Re: iis can't run smoothly

                  thank, no, it doesn't have permission to the folder. but now assign read and change permission to it already, but my site still require the username and password.

                  Comment


                  • #10
                    Re: iis can't run smoothly

                    Have you unchecked the "integrated authentication" and left only anonymous with the IUSR_SERVER1 specified?
                    Also what permissions have you specified NTFS or Share? because the "change" permission is not included under the ntfs security permissions.

                    Comment

                    Working...
                    X