No announcement yet.

DCPROMO not configuring DNS

  • Filter
  • Time
  • Show
Clear All
new posts

  • DCPROMO not configuring DNS

    This has been causing me grief for last couple of days and i have looked everywhere for hints.

    I have a brand new Fujitsu siemens PRIMERGY 300s2 that i have just installed server2003 on. This server needs to be a PDC of a new domain in a new forest. ecery time i run DCPROMO active directory installs as does DNS. On the re-boot the server takes ages to get passed the "network connections" stage then the log in screen apears with no domain. When i can finally log into the system and fire up Active directory the domain cannot be found.

    When i look in DNS the SRV records have not been configured and the only entries are the domain.local and the msdcs in the forward look up zone.

    I have followed the article posted on this site about configuring DNS before DCPROMO and can successfully register the server. All seems to be fine until the re-boot.

    Also the netlogon service will not restart after DCPROMO has completed

    things i have tried so far.

    isolating the server to a private network- same error.

    re-install- with update of raid drivers-same error.

    re-install without a raid configuration-same error.

    manually installing dns with the forward look up zones-same error.

    Any help or feedback would be appreciated

  • #2
    Re: DCPROMO not configuring DNS

    Do you have the server poinitng to itself for DNS resolution??


    • #3
      Re: DCPROMO not configuring DNS

      i've had a similar issue recently. not sure if it applies to you as well...

      the cause for was that the new domain controller was not allowed to register it's services in DNS. therefore, only the server itself thought it was a domain controller. no other domain controller recognized it as such.
      Yesterday we stood at the edge of the abyss. Today we are a step further...


      • #4
        Re: DCPROMO not configuring DNS

        I have got DNS pointing at the server!!!

        I have isolated the server so it has its own network. I have even replicated the scenario at home with same IP's as the server and it all works fine.(i think i did it to make sure DCPROMO does work in Server 2003 and i'm not making any 'schoolboy errors')

        i have monitored the installs of each machine and can pinpoint where it seems to fail.

        Active directory starts to install, then it installs DNS. So far so good. It then creates all the neccessary partitions and finishes up.

        Before the re-boot both the server and my test server have identicle dns entries.

        After/during the reboot my test server creates the neccesary srv records in dns and works fine. The real server takes ages to get past the "preparing network connections" stage, presuming it cannot write the files it needs.

        When i do get a login screen i enter username and password and try to enter the domain but it then trys to find the domain by creating a list. the only way to get out of this is to ctrl-alt del and you can eventually get in.

        When i then look at DNS it is exactly the same as it was before the re-boot, netlogon service will not start and has been marked for deletion 1075 error(the correct lanman entries are in the registry).

        Active directory will then not work and the whole thing is up the swanney!!

        The differences between the two machines are.

        raid 5+1hotspare disk configuration vs 1x40gb ide
        2xbroadcom network ports vs 1xintel
        Fujitsu Server Start used to configure OS( its a fancy way of creating an answer file) vs manual input of settings.

        is there anything i should install before launching DCPROMO. i have had the same error with win updates and without. In fact the only thing consistant with the whole thing is the netlogon error and the lack of srv entries.

        Fujitsu siemens support line just rings off the hook.....great support!!!

        Starting to look on e-bay for a very big hammer!!!