No announcement yet.

"Limited Connectivity" Message...

  • Filter
  • Time
  • Show
Clear All
new posts

  • "Limited Connectivity" Message...


    I currently am running an NT domain. I've set up a new Win2K3 domain alongside of the NT domain (same cabling - different network). I have a trust relationship set up between the two domains and most everything is running well.

    My DHCP server is located on my trusted NT Domain and the DNS server is located on the Win2K3 domain.

    I currently only have 1 computer (other than servers) that is logging onto the new W2K3 domain. When I cold start this computer and log in, I get the bubble that says "Limited Or No Connectivity". Upon investigation, I find that I have no connectivity to the network. Ipconfig shows me an auto-assigned (169.254.x.x) IP address. I cannot renew the ip address or ping either the DNS or the DHCP servers. After I restart the computer, it logs in properly with full connectivity.

    It seems like it should be a DHCP or DNS issue but I'm at a loss for direction.

    Any thoughts.

    Thanks everyone!!

  • #2
    Re: "Limited Connectivity" Message...

    the is a windows default IP... youll see it when you arent getting the correct DHCP info.

    manually input the DNS and WINS into the net properties box. this should correct the issue, but thats just a guess. im currently doing something similar with the 2 domains in my network.. an NT 4 domain and an AD 2003 domain.

    on the ipconfig /all, what does it list as your gateway, DNS, and WINS?

    things get tricky when the DHCP isnt on the new domain. its been a huge problem with my "migration" (i use the term migration loosely)

    do you have any kind of bridgehead between the two domains?
    its easier to beg forgiveness than ask permission.
    Give karma where karma is due...


    • #3
      Re: "Limited Connectivity" Message...

      Thanks for your response James.

      I am already explicitly specifying the DNS and WINS server.

      When I run ipconfig /all , here's what I get:

      IP Address:
      Subnet Mask:
      Default Gateway: NOTHING

      DNS: (which is in the new Win2K3 domain)
      WINS: (which is in the old NT4 domain)

      The strange thing about this is that if I restart the computer it boots, gets an IP address and connects fine. It works like this almost always after the first reboot! It's really quite maddening!!

      Thanks again.


      • #4
        Re: "Limited Connectivity" Message...

        Have you thought about installing a DHCP relay agent in the network without the DHCP server??


        • #5
          Re: "Limited Connectivity" Message...

          Can't be a missing relay; if so, it would never work while Gordon says it works on the second boot.

          Looks like a layer-1 problem. Set the link speed of the PC to fixed 100Mb/FD, see if that helps.

          If not, run a netmon trace on the dhcp server with a filter on DHCP traffic. That will surely tell you what is going on and will give you a hint on how to solve it.

          > manually input the DNS and WINS into the net properties box. this should correct the issue, but thats just a guess.

          No chance. DHCP comes before WINS/DNS.


          • #6
            Re: "Limited Connectivity" Message...

            Thanks for your responses.

            A few more notes...

            Strangely, I thought that the problem was solved or that I had mistated it. This morning, on the first boot, the laptop logged in with no problems. I shut it down and tried again in a while with the same result - no problems. I really hadn't changed anything so I was baffled.

            I shut down again and turned on the laptop again a while later and there was my problem again. It took two restarts this time before it would properly connect.

            I would agree that it seems to not be a DNS or WINS problem. DHCP seems a likely candidate.

            I explicitly stated 100/Full in the NIC configuration as you suggested but had the same result.

            I've tried running the laptop through a hub alongside of another laptop that is running Ethereal. I was able to capture the traces while I attempted the login.

            I haven't been able to pin down anything from the trace files. When the laptop gets its IP address and logs in properly the trace file indicates very clearly that fact.

            When it doesn't login, there doesn't seem to be any network communication coming from the laptop. Since it has no IP address at this point I'm looking for its MAC address. I haven't found it in the trace.

            One note. I mentioned that I'm using the DHCP server from my NT domain - I haven't made any changes to that DHCP server since setting up my Win2K3 domain. I just have a 2-way trust set up between the domains. Maybe that's a problem? I would think not, since it does work some of the time but I'm not sure.

            I think, next, I'll set up Ethereal on the laptop that I'm using to login. When it boots up and doesn't connect, I'll try renewing the IP address and see what Ethereal sees.

            Thanks for your help on this!


            • #7
              Re: "Limited Connectivity" Message...

              > One note. I mentioned that I'm using the DHCP server from my NT domain - I haven't made any changes to that DHCP server since setting up my Win2K3 domain. I just have a 2-way trust set up between the domains. Maybe that's a problem?

              I don't think so. DHCP really is a low-level network protocol.

              Sounds like the laptop NIC is behaving badly. Driver issue? Hardware?


              • #8
                Re: "Limited Connectivity" Message...

                Have you tried booting from a network bootdisk to check if your card will pick it up via that??

                What about using a PCMCIA NIC, if you can get one.

                Could be worth a try.


                • #9
                  Re: "Limited Connectivity" Message...

                  Thanks for your responses...

                  I have not tried a PCMCI NIC but I do have one. I'll give it a try.

                  It seems that it may be a configuration problem of some sort, although, I can't say where.

                  Here's more information. Just now, I started the laptop (cold). I received the "Limited connectivity" message.

                  I saw that the laptop had been given an APIPA IP address (

                  I started Ethereal and opened a new capture. I opened a Command window and tried to get a nwe IP address with IPCONFIG /RENEW.

                  I captured 4 DHCP Discover packets and that's it - the renew timed out unsuccessfully.

                  In looking at the DHCP Discover packets, I saw that the laptop was requesting the same APIPA IP address.

                  I tried IPCONFIG /RELEASE and then a /RENEW and had the same result.

                  I rebooted the laptop and everything worked as it should. I got a good 10.1.x.x IP address from my DHCP server.

                  One other thing of note: I was also monitoring the port statistics on my switch while this was going on. First, I zeroed the port stats. During the bad login attempts, while I was trying to renew the IP address with IPCONFIG /RENEW the switch port reported 4 "Oversized Packets". This would seem to correspond to the 4 DHCP Discovery packets.

                  During the good logins (after rebooting the laptop), the switch reported no bad packets of any kind.

                  It really seems to be a configuration problem somewhere. Just the fact that it works after a reboot but not after a cold boot is strange. Of course, to make matters even trickier - it sometimes will work on the first (cold) start. Not usually, but occasionally.

                  I'm going crazy over this one!



                  • #10
                    Re: "Limited Connectivity" Message...

                    check the event viewer in the laptop.
                    so that we may get more hint with regard to this problem.