Announcement

Collapse
No announcement yet.

Group Policy IE not updating

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Group Policy IE not updating

    Environment:

    Windows Server 2003 single domain
    Domain Functional: Level Windows Server 2003
    Forest Functional Level: Windows Server 2003


    Problem Description:

    We have a working GPO for the Internet explorer Home page URL.

    I made a change to the GPO Internet Explorer home page and set it to another site.

    The Problem is that the home page has not updated for the users logging onto RDS (Server 2008 R2 RS servers and Internet Explorer .

    The Change which I made was directly from the Server 2003 Core DC.
    The change was simply removing the home page URL and adding the correct new URL under User Configuration\Windows Settings\Internet Explorer Maintenance\URLs\Imported URLs\Home Page URL:

    The GPO in question has a WMI filter and was obviously working before, its been 3 days now and no change.


    What the users get now is still the old URL Home page. There is no indication this policy is failing either, when I run Group Policy Results from my Windows 8 machine Group Policy Management it shows that the GPO is the winning GPO for IE Home page.

    Not sure if this makes a difference but may be worth while mentioning, on the DC 2003 server I cannot view the GPO Settings via Group Policy Management where as on my Windows 8 machine I can. The changes I made had to be made from the DC as that's where the URL hoe page was originally set.


    I ran an RSOP from a test user and got the following message:

    The processing of Group Policy failed. Windows could not evaluate the Windows Management Instrumentation (WMI) filter for the Group Policy object cn={F17A443D-56CA-4826-92B3-1A05B0096CA7},cn=policies,cn=system,DC=domain,DC=l ocal. This could be caused by RSOP being disabled or Windows Management Instrumentation (WMI) service being disabled, stopped, or other WMI errors. Make sure the WMI service is started and the startup type is set to automatic. New Group Policy objects or settings will not process until this event has been resolved.


    To me this makes no sense. It was a simple change yet it seems as though the IE settings are hard coded and cannot be overwritten.
    There are no other policies which override this setting as previously stated, this is the winning GPO.
    Do I need to restart the Servers perhaps for the changes to take affect?
    Or do I need to modify the GPO via my Windows 8 GPM, User Configuration\Preferences\Control Panel Settings\Internet Options\
    But again that would make no sense since it worked before with the way it is.

    What is the best way of applying policies when you have an environment with Server 2003 DC's, Server 2008 Servers, Windows 7 and 8 workstations, Internet Explorer 8 or 9.

    WMI filters, using GPM on Win 7\8 or 2003.

  • #2
    Re: Group Policy IE not updating

    I managed to fix this. It seems I had to specify the home page URL under user Configuration\Administrative Templates\Windows Components\Internet Explorer\Disable Changing home page settings and set to enabled with URL home page.


    I would still like to know What the best way of applying policies is, when you have an environment with Server 2003 DC's, Server 2008 Servers, Windows 7 and 8 workstations, Internet Explorer 8 or 9.

    WMI filters, using GPM on Win 7\8 or 2003.

    Comment

    Working...
    X