No announcement yet.

2003 Server Standalone DNS times out NSlookup

  • Filter
  • Time
  • Show
Clear All
new posts

  • 2003 Server Standalone DNS times out NSlookup

    Greetings, I have a 2003 server acting as my email server and Primary external DNS. It has a public IP address and sits in my DMZ. Formerly this server was 2000 and it worked fine. Since switching to a new mail server program and Server 2003, my DNS has not been working properly. Fortunately my secondary DNS server is working and receiving updates from the primary. When I run nslookup from this server it gives an error saying it has timed out. This is probably simple but I can't see it. Thanks in advance for any suggestions.


  • #2
    Re: 2003 Server Standalone DNS times out NSlookup

    Do you have a reverse lookup record for the name server ? (I mean a PTR record for corresponding NS and A records of the DNS server itself)
    If not, this is a known issue with nslookup.exe - it expects the DNS server to have a PTR record.

    To verify that, run something like:
    [yada yada, timed out]
    >server (replace with your DNS server IP)
    >set type=ALL
    If the DNS server still times out, there is something wrong with the DNS config or service. If it does answer the query, all you need is to configure a PTR for the DNS server itself and you should be done.
    Guy Teverovsky
    "Smith & Wesson - the original point and click interface"


    • #3
      Re: 2003 Server Standalone DNS times out NSlookup

      Yes, I have a reverse lookup record. What is confusing me is that I can do nslookup, pointing to my secondary dns server, and it replies ok.