No announcement yet.

Help required for error message related to NAT with Event ID: 32003

  • Filter
  • Time
  • Show
Clear All
new posts

  • Help required for error message related to NAT with Event ID: 32003

    I am running Windows Server 2003 Enterprise Edition as a PDC and have got all XP Professional computers as client pc's. Whenever i restart my server i get the following Error recorded in my Event Viewer with following details:

    Event Type:	Error
    Event Source:	ipnathlp
    Event Category:	None
    Event ID:	32003
    Date:		12/5/2005
    Time:		20:05:27
    User:		N/A
    Computer:	SHUTTLE
    The Network Address Translator (NAT) was unable to request an operation of the kernel-mode translation module. This may indicate misconfiguration, insufficient resources, or an internal error. The data is the error code.
    For more information, see Help and Support Center at
    0000: 1f 00 00 00               ....
    On my server pc, i have two network cards with names of public and private. public one is connected directly to my DSL Provider phone line (no router in between) and the other private network adapter is connected to my private network through a switch. I usually need to dial to my DSL provider using PPPoE to start the internet.

    I have DHCP Server installed and configured for the private network adapter in the range to And my server is having IP address with subnet mask of and DNS of I also have DNS configured on my server.

    For the private network adapter i have manually set the ip address of and subnet mask of

    My server is also providing and doing the Routing and NAT Service to my XP Clients.

    Now, can you please tell me how can i make sure that i dont get the above error message???

    If there are any other details required to find the problem then let me know, i would be glad to provide.


  • #2
    Re: Help required for error message related to NAT with Event ID: 32003

    There no logic today to work with Windows NAT. The best solution is to buy firewall and ADSL router like Netscreen 5GT etc.

    To reslove this issue you may need to change private interface IP to: for example and the DHCP scope should be
    You need to set as defualt gateway to the clients (but not to the server) and setup it also as DNS/WINS server for clients and the server.
    You may need also to reconfigure the NAT.


    Best Regards,

    Yuval Sinay

    LinkedIn:, Blog: