Announcement

Collapse
No announcement yet.

Integrated auth and basic with default domain

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Integrated auth and basic with default domain

    Hi all

    We have several internal websites which run on members servers (Server 2003) in the domain. They can open web pages fine whilst logged into a computer in the office but when they open the page from home they are prompted for a username and password - this is fine and expected but they have to put in DOMAIN\username. I have put in the domain in default domain and realm but it still doesn't work.

    It only works if i untick Integrated Auth but then when logged in the office they need to type in a username and password instead of going straight in.

    Is there anyway around this?

    Thanks
    Server 2000 MCP
    Development: ASP, ASP.Net, PHP, VB, VB.Net, MySQL, MSSQL - Check out my blog http://tonyyeb.blogspot.com

    ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

  • #2
    Re: Integrated auth and basic with default domain

    Basic authentication doesn't use realm for authentication. Its only use is to display the value entered for realm into the username field of the client dialog.

    Digest authentication actually uses realm in the authentication process.

    My guess: This is why users are seeing it when they're in the office (basic is enabled). Try removing the realm information.

    Originally posted by Microsoft
    Optionally, you can enter a value in the Realm box, which configures the value of the Realm Metabase Property. If the Realm property is set, its value appears on the client's logon dialog box, when Basic authentication is used. The value of Realm is sent to the client for informational purposes only, and is not used to authenticate clients using Basic authentication.
    http://www.microsoft.com/technet/pro...62c91b797.mspx
    Last edited by ahinson; 25th October 2005, 06:24.
    Andrew

    ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

    Comment


    • #3
      Re: Integrated auth and basic with default domain

      Ok i have Basic and Integrated selected. It doesn't matter if i enter anything in Default Domain or Realm. What happens is I am prompted for a username and password.

      I enter my username as cp and my password. Then the username and password box appears and it has added intranet.wilberforce.local\ before my user name. It really needs to add wilberforce\

      I can get it to do this only if i turn off integrated authentication and then the username prompt will accept just cp (when i put wilberforce.local as the default domain). But i dont want that cause the website is primarily used inside the office and the integrated doesn't prompt.

      I hope this makes sense!
      Server 2000 MCP
      Development: ASP, ASP.Net, PHP, VB, VB.Net, MySQL, MSSQL - Check out my blog http://tonyyeb.blogspot.com

      ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

      Comment

      Working...
      X