No announcement yet.

Problem Accessing AD-Integrated DFS

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem Accessing AD-Integrated DFS

    I have an AD-integrated DFS. Our DCs and DFS root hosts are all on Server 2003 R2. We are using DFS-R for various replicated leaves. All has been working well for a long time.

    In a branch office, a server failed. It was a domain controller/file server. We took an existing server that was previously out of service and wiped out the data volumes, brought it to the site, promoted it to a DC, installed DHCP, DNS, etc. We restored files and shares.

    All seems to be working okay except for one issue. This server cannot access the DFS. I observed this initially when trying to Browse into the \\domain\DFS. An authentication dialog would pop up. When I tried to use the DFS management console to view the DFS, it would enumerate the AD-integrated DFS and let me add it in for viewing and management, but it would throw an error when trying to view the contents. If I run the command dfscmd /view \\domain\dfs, I get the following error:

    System error 5 has occurred.
    Access is denied.

    By the way, I get similar errors if I try to do any of the above via \\RootHostServer\DFS or even \\IPofRootHost\DFS

    Interestingly, I can successfully add a new namespace to this server and browse into it. So DFS management is okay. It is a corruption on how it reads the existing AD-integrated DFS.

    As I said, otherwise this server seems to be fully functional both as a DC and file server, and I even started to replicate some DFS leaves to this server. It just can't view or manage the DFS.

    What can I do to clean up this issue?

  • #2
    Re: Problem Accessing AD-Integrated DFS

    try reinstalling the DFS role, and re-adding it to the DFS replication set ?
    Please do show your appreciation to those who assist you by leaving Rep Point