Announcement

Collapse
No announcement yet.

RDP Web on Windows Server 2003 question.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RDP Web on Windows Server 2003 question.

    I have seen on a few message boards that is is possible to use TSWEB to access more than one server/desktop behind a nat network.

    I wish to use this for remote administratioin and maitnance of a network.

    My issue is that in my attempts to do this on my home network I cannot get it to work.

    I can connect to the server it runs on but not any other pc on the network.
    I am connecting from a remote server not on the lan.
    (the network has wins running BTW)

    Has anyone has success with this?

    I have a sneaking suspiscion that i need a domain to do this (I don't have on at home) I think I will test this on a domain and see if thats my probem.

    Any insight to this will be most welcome.

  • #2
    TSWEB

    Unless you change the listen port on one machine and alter the client prior to connecting this won't work.

    If you're trying to conect to more than one private IP behind the NAT and using a 1 (public IP) to many (private IPs) NAT environment this will not work. This environment requires an explicit port to ip relationship (port forwarding etc) in order for data to properly transverse the NAT. If using Multi-NAT and a 1 (public IP) to 1 (private IP) NAT it would be possible because port 3389 belongs to each private ip which translates to 1 public ip and vis versa.

    You can always piggy-back from one machine to another.

    i.e. First connect to 192.168.0.1, then from this machine connect to 192.168.0.2

    Hope that helps.

    ---

    How do I change the listening port in the Windows Terminal Server Web Client?

    You may wish to change the default listening port from 3389 on Windows XP and .NET Server clients:

    1. Use Notepad to open %system root%\Web\TsWeb\Connect.asp.

    2. Locate the entries that start with MsTsc.AdvancedSettings2.

    3. Position the cursor after these entries and add a line:

    MsTsc.AdvancedSettings2.RDPPort = nnnn

    where nnnn is the new listening port.


    To change the Terminal Server to listen on a new port:
    1. Use the Registry Editor to navigate to:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Contro l\Terminal Server\WinStations\RDP-Tcp.

    3. Double-click the PortNumber Value Name, a REG_DWORD data type, and set the data value to the listening port, using the Decimal Radix.

    4. Stop and re-start Terminal Services.
    Andrew

    ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

    Comment

    Working...
    X