No announcement yet.

RRAS PPTP VPN tunnel "freezes" up

  • Filter
  • Time
  • Show
Clear All
new posts

  • RRAS PPTP VPN tunnel "freezes" up

    Good afternoon to you all! I'm a frequent reader of this wonderful site, it's helped me out so much in the past, but this is my first time posting.

    I've been around the site a few times looking for a possible solution to this problem, and I've searched the Internet for the last week as well, unfortunately with no success. I'd be eternally grateful (reputation definitely given).

    We have a handful of remote users who work from home. My predecessor used the free version of Hamachi to allow them to connect to our single Server 2003 DC, which allowed them to access both File Shares and Exchange 2003 for their emails.

    Since I've taken over, I've been slowly rolling out VPN links using the RRAS built into Server 2003, with reasonable success - our staff are happy that the link is faster, they can access their emails quicker, etc.

    Not everything's perfect though. We have a few staff, some of which occasionally work from the same office, that are encountering problems with their links. They can connect to the server using PPTP VPN absolutely fine, can ping machines on the network, access their emails, file shares etc...for a while. The time they can stay connected varies, but one thing is the same in all cases - although it looks like they're connected to the server (both in the RRAS console and on the client machine), no data is sent or received through the link.

    At this stage, pinging the server from the client times out - it shows data is sent from the client, but this data is not received by the server. Ditto vice versa. The only way this is solved is for the client to disconnect from the link, wait a few seconds, and then reconnect. If this was just occasionally it would be OK, but it happens three or four times a day, sometimes more.

    The server is sat behind a Draytek Vigor2800 series router. We're a small charity, and so unfortunately the one server contains everything - DNS, DHCP, RRAS, Exchange and File Sharing.

    I've tried modifying the MTU of the remote clients, with no success. Although the connection between the server and the client freezes, the client can still browse the Internet (I've left "Use Default Gateway on Remote Network" unticked).

    All the traffic is going through a single NIC on the server - I'm looking to add a second NIC specifically for RRAS traffic, but I'm not sure how much of a difference this will make.

    As I've not been able to find information anywhere else about this specific problem, this could be a long shot, but it'd be fantastic if someone here is able to help, or even point out something I may have missed.

    Thanks in advance

  • #2
    Re: RRAS PPTP VPN tunnel "freezes" up

    Can't you terminate the VPN access on the vigor?
    Technical Consultant

    "No matter how secure, there is always the human factor."

    "Enjoy life today, tomorrow may never come."
    "If you're going through hell, keep going. ~Winston Churchill"