Announcement

Collapse
No announcement yet.

Unable to RDP

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to RDP

    Has anyone ever come across this one.

    For no apparent reason I am not unable to remote desktop onto our file server (SH-NAS1) The message I see is attached.

    I have checked and RDP is enabled. Iím using the domain admin account to access the box.

    I have VNC installed on the box & can connect using this.

    I can also RDP from this box to another box.

    Windows updates are disabled.

    Any suggestions where to start?
    Attached Files

  • #2
    Re: Unable to RDP

    sure we had a similar thread on this recently.

    - when did the problem start occuring
    - has a reboot occured since the problem started
    - can you telnet from another computer to that file server on port 3389? What happens.
    - Can you telnet from the SAME server to port 3389 on itself? What happens
    - can you use RDP from a different computer to the file server?
    - is there anything in the event logs?
    - do you possibly have the new RDP client with NLA installed, and requiring network authentication ?
    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

    Comment


    • #3
      Re: Unable to RDP

      - when did the problem start occurring
      Around 2 weeks ago

      - has a reboot occurred since the problem started

      From what I can remember it looks like a scheduled reboot caused this issue

      - can you telnet from another computer to that file server on port 3389? What happens.
      No - message is

      C:\>telnet sh-nas1 3389
      Connecting To sh-nas1...Could not open connection to the host, on port 3389: Connect failed

      C:\>

      - Can you telnet from the SAME server to port 3389 on itself? What happens
      Yes - telnet connects & sits on a blank screen waiting for a command,

      - can you use RDP from a different computer to the file server?

      No - I get the same results form any other PC

      - is there anything in the event logs?
      No Ė Iíve been through the logs more than once and thereís nothing in there

      - do you possibly have the new RDP client with NLA installed, and requiring network authentication ?

      Not as far as Iím aware, this should just be the standard RDP with Server 2003 SP2

      Comment


      • #4
        Re: Unable to RDP

        check for firewall rules and security policies.

        If the host itself can connect, but others can't, this suggests a transient network issue to my mind

        what happens if you try and rdp out of that server onto a different one.. does that work ?
        Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

        Comment


        • #5
          Re: Unable to RDP

          Run netstat -an | find "3389" on the server.
          If 3389 is not listed, disable and re-enable remote desktop again.
          Also check if the Terminal Services is running (I believe this is necessary)
          Marcel
          Technical Consultant
          Netherlands
          http://www.phetios.com
          http://blog.nessus.nl

          MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
          "No matter how secure, there is always the human factor."

          "Enjoy life today, tomorrow may never come."
          "If you're going through hell, keep going. ~Winston Churchill"

          Comment


          • #6
            Re: Unable to RDP

            Remove VNC. I believe that was the fix in the thread tehcamel was referring to.
            1 1 was a racehorse.
            2 2 was 1 2.
            1 1 1 1 race 1 day,
            2 2 1 1 2

            Comment


            • #7
              Re: Unable to RDP

              not really.. :P I was simply saying it had been covered recently, and there might be tips in there

              removing vnc may actually resolve the issue, I dunno.. if it does, great
              Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

              Comment

              Working...
              X