Announcement

Collapse
No announcement yet.

Disable time sync on windows 2003 R2 server

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Disable time sync on windows 2003 R2 server

    Hi all, I am in need of your advice…
    Issue: one of our DB apps is generating reports to be sent to diff. locations that have diff time zones.
    I have been asked to provide a solution so this particular server (this is a 2003 R2 member server on a domain) would be set to use “Greenwich Mean time” and not to get time from the PDC, which is in CST zone.

    Steps I took to test: I have set this server to use that time zone above
    Unchecked “Automatically Adjust clock” box
    Disabled Windows time service.
    Removed the following reg key: windows.microsoft.com
    After removing that reg key time stays as to what it was manually set to be. So, all is good until I reboot the server. After reboot it reverts back to its orig time.

    Question: is there a way to change something so the time stays even after rebooting the server? Could it be that it could introduce some potential issues – like not being able to log onto that server anymore, because of the time difference exceeding 5min. etc.?
    Please advice.
    Thanks
    Regards,
    John

  • #2
    Re: Disable time sync on windows 2003 R2 server

    You should be able to have the server syncing its time from the pdc and simply change the time zone on the server to the required zone. That way the time will always be in sync with the DC but the zone (and the required time on the server) will be correct. I just quickly tried it in my test domain and it works as expected
    Last edited by hazey; 21st April 2010, 06:11.

    Comment


    • #3
      Re: Disable time sync on windows 2003 R2 server

      Thank you for your reply.
      I maybe did not communicate that clearly, but what I am trying to achieve is: have system time on that member server set to "Greenwich mean time" + time zone, which I did. So after that it 6 hrs. ahead from the PDC. This is fine at it stays on like that untill I reboot this server. After reboot it reverts back to PDC's system time - which is CST.
      Any other ideas?

      Thanks
      Regards,
      John

      Comment


      • #4
        Re: Disable time sync on windows 2003 R2 server

        check out the article below about inconsistent time/zone settings its sounds like the issue you are experiencing.

        further to my post yesterday in my test domain i have the DC set at

        (GMT +10) Canberra Melbourne Sydney
        (time on server as of this post 9:46 am)

        and a member server set at

        (GMT) Greenwich Mean Time : Dublin, Edinburgh, Lisbon, London
        (time on server as of this post 12:46 am)

        i have rebooted the member server and the settings above remain consistent so what you are trying to achive should work okay without disabling the time sync.


        http://searchwindowsserver.techtarge...218143,00.html

        Comment


        • #5
          Re: Disable time sync on windows 2003 R2 server

          sorry, my mistake....
          What I am trying to achieve is:
          On the member server have time set and stay on Central Standard Time - which I did.
          But the time zone I need stay on Greenwich Mean Time. Like I mentioned it stays with these parameters until I reboot. After reboot the system time on that member server jumps forward to match the time zone of GMT.

          any other ideas? Thanks
          Regards,
          John

          Comment


          • #6
            Re: Disable time sync on windows 2003 R2 server

            ah in that case i would suggest that this is a bad idea (even if you can get it to work) Time synchronization is extremely important in a windows domain and yes you will experience logon/authentication issues along with a host of other problems if the member server is out by a big time difference.

            Comment


            • #7
              Re: Disable time sync on windows 2003 R2 server

              Thanks for replying.
              I think as far as system time difference there would be no diff between the Member Server and the DC.
              The only difference would be the Time Zones: DC- CST and Member Server - GMT.
              Not sure if diff. processes checks Time Zones in addition to system time...
              I think i will have to tell them that this is not going to work, or they have to remember to change time if member Server is rebooted.

              regards,
              Regards,
              John

              Comment


              • #8
                Re: Disable time sync on windows 2003 R2 server

                Hi John,

                what you're trying to do should be fine. There are plenty of organizations that span several time zones.

                The question is what is changing it back to CST? It's not the time sync.

                Do you have any startup scripts that run? Do you have any GPO's in place?
                Regards,
                Jeremy

                Network Consultant/Engineer
                Baltimore - Washington area and beyond
                www.gma-cpa.com

                Comment


                • #9
                  Re: Disable time sync on windows 2003 R2 server

                  thanks Jeremy...
                  Yes we have a GPO that has windows NTP client enabled. When this setting was affecting that member server it would revert back to GMT time after 45 min. to match the time zone.
                  I have modified registry key on that member server to not to use the NTP client. So, now it works fine (doesn't revert back) until I reboot the server.
                  If I run net time /querysntp on that serevr now it has nothing as current SNTP value, before it was showing windows.microsoft.com
                  So, I think after reboot it just changes the time to match the time zone which is set to GMT.
                  I tried simple cmd script to se static time value and it works, but not sure how to get variable and get time lets say from the DC which would be CST and then set to CST and the time zone would stay GMT on that Member Server.
                  I hope I was able to explain this properly...
                  Thx
                  Regards,
                  John

                  Comment


                  • #10
                    Re: Disable time sync on windows 2003 R2 server

                    I'm a little confused.

                    Are you changing the time or the time zone? When syncing with a time server it syncs the UTC and the computer will display the proper time based on it's time zone. The time zone won't be changed because of a time sync.
                    Regards,
                    Jeremy

                    Network Consultant/Engineer
                    Baltimore - Washington area and beyond
                    www.gma-cpa.com

                    Comment


                    • #11
                      Re: Disable time sync on windows 2003 R2 server

                      I am changing the time zone from CST (which is original) to GMT (which what we need to be).
                      When you change the time zone it automatically changes time to match the time zone. But I don't want to change the system time - time I want to stay on CST, but time Zone I want to be GMT.

                      thx
                      Regards,
                      John

                      Comment


                      • #12
                        Re: Disable time sync on windows 2003 R2 server

                        I'm losing the plot/will to live here
                        So, if your DC is 1200 CST you want your SQL Server to be 1200 GMT (equivalent to 0700 CST)

                        If so, I don't think you can do it without breaking Kerberos due to the time skew
                        Tom Jones
                        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
                        PhD, MSc, FIAP, MIITT
                        IT Trainer / Consultant
                        Ossian Ltd
                        Scotland

                        ** Remember to give credit where credit is due and leave reputation points where appropriate **

                        Comment


                        • #13
                          Re: Disable time sync on windows 2003 R2 server

                          Ah, now I see.

                          Well that would explain why it's changing. I believe it gets the time from the BIOS but I'm not positive.

                          You shouldn't have the time off like that as it breaks authentication. Why do you need the time zone to be GMT but the time to be CST? Why not just use CST or GMT in the actual time?
                          Regards,
                          Jeremy

                          Network Consultant/Engineer
                          Baltimore - Washington area and beyond
                          www.gma-cpa.com

                          Comment


                          • #14
                            Re: Disable time sync on windows 2003 R2 server

                            I tried BIOS as well, same thing...
                            I was trying to help one of our database developers, they send diff reports to diff locations and wanted them to be stamped with CST system time.

                            thank you guys,
                            I just told them they need to write a procedure to reset time if server is rebooted....
                            Regards,
                            John

                            Comment


                            • #15
                              Re: Disable time sync on windows 2003 R2 server

                              You can't do this without breaking the system.

                              In a domian enviornement you are allowed a maximum of 5 mins of a time difference before things start breaking.

                              Comment

                              Working...
                              X