No announcement yet.

\WINNT\SYSTEM32\CONFIG\SYSTEMced is missing or corrupt

  • Filter
  • Time
  • Show
Clear All
new posts

  • \WINNT\SYSTEM32\CONFIG\SYSTEMced is missing or corrupt

    Tricky problem here.

    5-6 year olf server with sbs 2000. The server has 2 IDE drives near the bottom of the case and definately has a RAID 1 mirror, according to the Bios, which i assume are these 2 IDE drives at the bottom, the server also has an IDE drive at the top in an almost armoured like caddy which also has a key lock whereby if you turn the key it powers off the drive and can then also pull out the caddy.

    Here are the apparent possible things that were done to cause this SYSTEMCED error.

    1) The tape was removed from the tape drive while the server was running. (I have googled one instance where they said this caused the problem).
    2) The top drive (the armoured caddy) was powered down while the system was booting or even running, it was powered down by turning the key which powers off the drive, i am not sure if this is a backup drive or the system drive.
    3) The server was powered off while running "hard reset" etc

    So micirosoft KB says to boot to the recovery console and copy a backup of the SYSTEM registry file from winnt\repair\system to \winnt\system32\config or copy from \winnt\repair\regback\system c:\winnt\system32\config the latter being a more recent backup the first being the default SYSTEM file.

    So i booted to the RC and i am presented with a C:\ command line. I don't need to log in or anything.

    I do a dir and i don't see any winnt directory all i see are 4 folders all showing 0 bytes and one is the system volume information.

    I do a map and it shows 4 drives one beging the tape drive, one the dvd drive, one the floppy and the c:\ drive.

    I assume the raid drives are not being shown as i should have pressed F6 to load the Raid drivers during the setup part on route to the recovery console.

    Can anyone meake any sense of this?

    To me it means that the 2 drives at the bottom in RAID are the system drives, and the top drive a backup drive but why would powering off a backup drive corrupt the regsitry?

    I thought maybe boot into a live linux CD like puppy Linux and manually copy a backup SYSTEM file from \winnt\repair\regback\system into system32/config?

    What do you think?

  • #2
    Re: \WINNT\SYSTEM32\CONFIG\SYSTEMced is missing or corrupt

    yeah boot up with some sort of livecd that has raid support. if puppy doesnt work for you, try this:

    if even that cd isnt allowing you to mount the partitions on the RAID, and assuming this a custom built server and not a major manufacturer, open the case and find out what type of motherboard it has in it. that will give you an idea of what sort of raid controller it has on it.

    im guessing that you are getting the "\WINNT\SYSTEM32\CONFIG\SYSTEMced is missing or corrupt" message while its trying to boot? and im guessing you have already tried the other options from the F8 boot menu? (last good known profile/safe mode, etc)?

    if you can get it up again by copying over the old system profile, thats good, but even then, the first thing you need to be doing after that is saving all of the data off of the raid array and preparing to do a fresh install--- preferably on brand new drives. in fact, if you can indeed access the array from a linux livecd that would be my first suggestion. save anything and everything you can, by hand, and then after doing that attempt to copy the 'backup' SYSTEM over the currently corrupt or missing one.

    whatever you do, i would make save everything possible. if you have a copy of Acronis True Image, i would recommend booting off of it and trying to make a full image of the RAID array to another drive, perhaps to a spare USB external. lookup 'diamond boot cd' or 'hirens boot cd' if that is the route you decide to take.


    • #3
      Re: \WINNT\SYSTEM32\CONFIG\SYSTEMced is missing or corrupt

      Thanks for that. Yes getting while trying to boot, the progress bar starts(win 2000 server is loading etc) and stops after about 2 bars then the error. And yes it's a custom build entry level server.

      I do indeed have Acronis, i use Backup and recovery 10 with universal restore, has worked well for me on other jobs. Although i have never actually used it on a Raid array, but i know Acronis has the option to clone the array, so i guess the raid drives will just show as one in Acronis and then either image that drive or clone it. I think an image would be better than a straight copy(clone) over.

      I forgot i would also need raid support on the linux live cd so good point there, i know that the raid controller is a promise controller ATA 66.

      I guess if i do copy of the backup SYSTEM file i don't think i will lose any settings as the server has not been touched in years.

      If copying the file over does work why do i still need to image the array so urrgently as you say?

      thanks again.


      • #4
        Re: \WINNT\SYSTEM32\CONFIG\SYSTEMced is missing or corrupt

        "i know that the raid controller is a promise controller ATA 66."

        ah, good-- at least its something standard. yeah, acronis will probably see the array as simply one physical volume, maybe with multiple partitions, but yeah either way acronis will let you take that entire physical disk and dump all of it into one single image file that you could restore back 'just in case' if you need to revert. also, if you needed to just restore files later on to a 'fresh install', you will be able to pull them out individually from the image file.

        "If copying the file over does work why do i still need to image the array so urrgently as you say?"

        because usually, in my experience, if something corrupted SYSTEM, there is something very wrong and there are probably going to be more problems ahead. i would recommend doing a Memtest86+, letting it make 1 complete pass on the ram, and then possibly doing a drive sector test with something like SPecialFDISK or Acronis Disk Director if it has that option.

        it is possible that the SYSTEM file was corrupted by some strange one time fluke like the server having an improper shutdown, but its better safe than sorry (especially depending on how critical this servers function is)


        • #5
          Re: \WINNT\SYSTEM32\CONFIG\SYSTEMced is missing or corrupt

          It's good to talk to a pro. That is actually what i thought as well, that there well could be more serious things going on, either that or if i did restore the registry like i said then there may very well be other settings that are not restored/configured as the backup registry is out of date, meaning that you could well find yourself picking away at numerous things trying to brnig the server back to life again.

          Maybe another option would be to upgrade to sbs 2003,a bit pricey though.

          Or i beleive sbs 2000 has a repair install option(just liek win xp) as well if all else fails, i think this also means that i would have to reinstall service packs/updates and possibile various other settings as well.