No announcement yet.

RPC Server Unavailable

  • Filter
  • Time
  • Show
Clear All
new posts

  • RPC Server Unavailable

    HI Team,
    I have a windows 2003 enterprise server and citrix PS 4.5 is also installed on it.
    But after some time say about 2 -3 days it gives error message RPC server unavailable,the setting of RPC (Remote Procedure call) is set as resatrt the host if it fails but my server never rebooted whenever we get the error message.this shows that RPC service is fine but it dependent service is of the dependent service is of SAP application.
    can anyone help me regarding this.

  • #2
    Re: RPC Server Unavailable

    I sounds like your Citrix server is the RPC client in this instance. More than likely one of your Citrix apps is trying to make an RPC connection to a backend server and it's failing for some reason.

    When the server throws this message is there a specific application that then fails? Any errors in the application log?


    • #3
      Re: RPC Server Unavailable

      Yes there are several errors like as below
      Application Logs

      Source : MetaFrameEvents
      Category : Printer Management
      Type : Warning
      Event ID : 1103

      An error occurred while retrieving client printer properties. Default printer properties will be used instead.

      Source : CitrixHealthMon
      Category : None
      Type : Error
      Event ID : 2005

      Test threshold reached for the test XML service test. the action to be alert only will now be performed.The test is assumed to be in a failed state, and no more failure message will be returned.An information message will be sent when the test is passed.
      Debug information
      Test failure1. Error code: 37
      Test failure 5. Error code 37.

      System log

      Netlogon and Browser errors in System logs.

      Note: Some Sap application is running on this server and it is not working whenever we get RPC error. and one more thing they might connect to some other host to get database.
      I tried Citrix XML service restart after that RPS error but it didn't worked.
      Any other thing u want to know please let me know.