Announcement

Collapse
No announcement yet.

backup to NAS

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • backup to NAS

    I have 2 Win2003 servers, serverA is our file server and serverB is setup as a NAS with 4 x TB drives used strictly for backup purposes. Besides remote management serverB is only used for backups. ServerA is multi-homed with one NIC servicing the domain users on a class A 10.x.x.x IP with the default gateway set and “register this connection in DNS” set as well. The other NIC on serverA is using a class C 192.168.0.101 without a default gateway and without the “register this connection in DNS” checked.
    ServerB is also multi-homed the same as serverA.
    We also created entries in each hosts file on the servers pointing to each other. When I open a command prompt and ping the NETBIOS name of serverB from serverA the ping reply shows using the class C NIC which is what I expected.
    However this is what I do not understand, during a backup with Backup Exec 11d when I monitor network performance using Task Manager on serverA it shows both NICs however it shows the Class A NIC as being used for the backup which is not what I want to happen. Is there a bug in the network monitoring on win2003 servers? I have yet to load up a packet monitoring package and start monitoring at that level and I would rather not have to. Has anyone here had the same experience?
    Thanks for the help!

  • #2
    Re: backup to NAS

    I think it's more a case of which NIC is being used in BackupExec. The setting is configurable in the options and I believe the default is to use any available network interface. I would have a look at those settings.

    Comment


    • #3
      Re: backup to NAS

      Very interesting thanks for the reply. I found where I can select the network interface to use however I wonder how selecting the class C interface will affect my remote agent jobs. I backup some folders on remote PC throughout the domain and by selecting BE to use the class C interface I wonder if those jobs will fail. It is worth a try I guess. I only want BE to use the class C interface when creating/writing the backup files. I'm guessing the BE jobs that access the class A network for reading data will fail if I assign the class C as the only interface to use.
      You maybe wondering why I setup the backups this way, the main class A network is 100MB while the class C link between serverA and serverB is 1GB. I was after getting the backups to complete faster over the 1GB link and reduce loads on the main class C network switch. In theory it should work.

      Comment


      • #4
        Re: backup to NAS

        Keep us posted on your progress.

        Comment


        • #5
          Re: backup to NAS

          As I suspected, I just edited a job that does remote backups to use the class C NIC and it failed.
          The Media Server was unable to connect to remote machine: <Server Name> using selected subnet: 0.0.0.0.

          Comment


          • #6
            Re: backup to NAS

            As far as the servers being multihomed is concerned:

            Are both NIC's connected to the same physical subnet?

            Are they connected to different physical subnets?

            Does the backup server have a NIC connected to both subnets?

            Can you post more info on the ip addressing used on both NIC's of the servers and backup server?

            Comment


            • #7
              Re: backup to NAS

              Keep in mind I want to remove backup (writing to files) traffic off the main 100BM switch.
              Domain uses a class A network schema 10.x.x.x network mask of 255.255.224.0
              ********************************************
              ServerA main file server with BE11d installed with jobs that use the remote agent to backup folders on computers.
              NIC1
              IP 10.1.1.7 SM 255.255.224.0 DG 10.1.1.1

              NIC2
              IP 192.168.0.102 SM 255.255.255.0 DG blank

              hosts file on ServerA.
              192.168.0.101 ServerB
              ********************************************
              ServerB
              NIC1
              IP 10.1.1.84 SM 255.255.224 DG 10.1.1.1

              NIC2
              IP 192.168.0.101 SM 255.255.255.0 DG blank

              hosts file on ServerB
              192.168.0.102 ServerA
              ********************************************
              NIC2 on ServerA and NIC2 on ServerB are connected with a cross-over cable.
              NIC1 on ServerA and NIC1 on ServerB are connected to the main network switch.
              like I was saying opening a dos box on serverA and typing in "ping serverB" will result in a reply from the class C NIC which is exactly what I want.
              Also a note, not sure if it means anything. In BE when I create the "backup-to-disk folder" I have to use the netbios name not the IP example \\serverB\<sharename> I tried using the IP like this \\192.168.0.101\<share name> but BE just times out.
              Thanks again for the help. It maybe that BE is just not able to work the way I want it to.

              Comment


              • #8
                Re: backup to NAS

                In the Network and Security properties of the backup job, when you selected the class C NIC did you also select the protocol and subnet or are they set to "any available"?

                Comment


                • #9
                  Re: backup to NAS

                  left them at default "any available".

                  Comment


                  • #10
                    Re: backup to NAS

                    Try setting the protocol to IPv4 and the subnet mask to the mask of the class C NIC.

                    Comment


                    • #11
                      Re: backup to NAS

                      I decided to do a little tinkering, I put my setup back to the original and decided to firewall NIC1 on serverB with an exception for "remote desktop" only. I left NIC2 un-checked in the firewall setup basically leaving it wide open on serverB. Low and behold the ^%#$% thing is working using NIC2. I did not want to change the connection order on serverA but I think that might have made a difference. The reason for leaving the connection order at NIC1 on top was to have network users with the most priority.
                      Basically I forced windows to use NIC2 for traffic between serverA and serverB.

                      Comment

                      Working...
                      X