Announcement

Collapse
No announcement yet.

DNS and UNC problem.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • DNS and UNC problem.

    SERVER01.DOMAIN.LOCAL
    : 10.110.210.252
    : Holds FSMO Roles
    : Primary DNS server

    SERVER02.DOMAIN.LOCAL
    : 10.110.210.250
    : Pointed to SERVER01 for DNS
    : Member Server



    From SERVER01, trying to browse to \\SERVER02 will show shares, but cannot open them. Error received is: "Configuration information could not be read from the domain controller, either because the machine is unavailable, or access has been denied."

    Browse to \\10.110.210.250 (SERVER02 IP), shares show up, and are accessible.

    Browse to \\SERVER02.DOMAIN.LOCAL and the shares show up, and are accessible.

    This leads me to beleive that there is a problem with DNS. Everything looks clean as far as I can tell. When the servers ping each other the FQDN gets resolved, ie, server01.domain.local

    The same is true if you try to access SERVER01 from SERVER02

  • #2
    Re: DNS and UNC problem.

    Do oyu have wins installed???

    YOur DNS is working fine as you can access it using the FQDN.

    Comment


    • #3
      Re: DNS and UNC problem.

      WINS is installed on of the servers. Can't recall which right now. One of the servers was pointed to it but I removed that setting. I was not able to reboot, but did do a repair on the network connection with no change to the problem.

      Would a reboot help?

      Comment


      • #4
        Re: DNS and UNC problem.

        Are you using DFS?

        Are there CNAME records for these servers?

        Are there multiple A records for these servers?

        Comment


        • #5
          Re: DNS and UNC problem.

          Originally posted by joeqwerty View Post
          Are you using DFS?
          Are there CNAME records for these servers?
          Are there multiple A records for these servers?
          There are no CNAMES in DNS at all, so that's clean....

          Each server has one or two other A records. I am partially aware that this can cause issues with SMB related things but no real first hand experience. I can assume that this is about to change.

          So there are additional A records. I am using the actual server names to access them and not the "additional A records" so SERVER01 and SERVER02 are the REAL names of the servers.

          Do I need to get rid of those records?

          Comment


          • #6
            Re: DNS and UNC problem.

            Having multiple DNS records (A or CNAME) can cause this type of problem but usually only for SMB communications when you're using the "alternate" name (meaning the name that is not the NetBIOS name of the server). I'm not entirely sure if relates to the problem you're having but it struck me as very similar. Try removing the additional DNS records, flush the DNS cache on the Server01 and Server02 and see if it makes any difference.

            Comment


            • #7
              Re: DNS and UNC problem.

              Time to complicate things.

              I am connected to the site in question with a Cisco VPN client.

              I can access \\server1 and \\server2 just fine!!!! but not if I am on the local subnet.

              Does this help anyone diagnose?

              Comment


              • #8
                Re: DNS and UNC problem.

                desperation bump.

                Comment


                • #9
                  Re: DNS and UNC problem.

                  Check your DNS server that can it query Wins for unresolved records. I do not have DNS server near me . If you see DNS server tabs , you will find WINS tab and there you can define you WINS server address. When dns server will not be able to find dns record for the device, it will consult WINS server.

                  Comment


                  • #10
                    Re: DNS and UNC problem.

                    Are your WINS servers replicating properly???

                    How many WINS servers do you have on site???

                    Do you have the WINS records on both servers for each other???

                    Comment

                    Working...
                    X