No announcement yet.

Domain Controller missing from Active Directory

  • Filter
  • Time
  • Show
Clear All
new posts

  • Domain Controller missing from Active Directory

    I have a troublesome issue that I have been working on for over a week now. One of my clients suddenly developed a problem with their Windows 2003 server and Active Directory where they were unable to add any new workstations to the domain.

    There is only one DC and no other servers in the domain.

    netdiag /fix only found an error with the Netcard queries test.

    dcdiag /v everything passes.

    nltest /dnsgetdc:<domain_name> completes successfully.

    nltest /dsgetdc:<domain_name> completed successfully

    gpotool showed no errors.

    The error when adding the workstations indicate that the domain controller was successfully located in DNS but was unable be found. I have tested connectivity between the workstations and the server, virus scans.

    I stopped netlogon, removed the DNS zones (both the primary and the _msdcs zones), deleted netlogon.dns and netlogon.dnb, recreated the zones and started netlogon. i also flushed the DNS cache and forced ipconfig /registerdns.

    I tried nltest /dsregdns.

    I upgraded the server to service pack 2 and updated all missing patches to make it current.

    Everything appears to be ok but the workstations still give the same error. I am desperate for a solution to this but I cannot seem to find one online as yet.

  • #2
    Re: Domain Controller missing from Active Directory

    What exactly is the error that is reported by a client when you attempt to join it to the domain?

    Does this happen with more than one new client? Are you able to remove an existing client and then rejoin it?

    Presumably, judging from your description, existing clients have no problem contacting the server?
    A recent poll suggests that 6 out of 7 dwarfs are not happy


    • #3
      Re: Domain Controller missing from Active Directory

      you probably "lose" your rid master

      run netdom query fsmo
      see which dc hold the rid master

      it could be down
      so you can seize the role to a functional dc


      • #4
        Re: Domain Controller missing from Active Directory

        Do you have sufficient CALS?

        Can you post a screenshot of the error?

        Have you tried populating the DNS suffix as shown in the attached image?

        Click image for larger version

Name:	dns-suffix.jpg
Views:	1
Size:	66.7 KB
ID:	464113
        Joined: 23rd December 2003
        Departed: 23rd December 2015