Announcement

Collapse
No announcement yet.

Downloading from MS...non-stop

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Downloading from MS...non-stop

    I have a WIndows 2003 Server which is used just for BES and WSUS. Pretty much nothing else is installed on this server.

    Basically we got a notification from the ISP by email that we had used nearly 80% of our 50GB monthly limit in 3 days.

    I had to investigate and found this server to be the culprit. Using the firewall I managed to throttle the connection down to 5k for the internet.

    I looked on the firewall and it tells me that this server has only 2 connections open:

    83.170.87.122
    and
    213.199.149.114

    Whois tells me the first is UK2.net (I dont know who these are) and the 2nd is Microsoft Data Centre.

    Naturally the first thing I do i remove WSUS, however the uninstall failed and I had to follow other instructions to remove it manually. No now there are no WSUS Services at all...yet the download keeps going.

    Im at a loss of what it could be or what to do to get rid of it.

    AV etc is all up to date....what else could be downloading all this? Rebooted after each stage but the bandwidth monitor I have tells me its still trying to download....

  • #2
    Re: Downloading from MS...non-stop

    Well, did you read the WSUS manual ? how to configure ? because probably you have downloaded everything that is available for Microsoft Software, every operating systems and office products, and in every language. Check that out.

    Regards
    Kevin

    Comment


    • #3
      Re: Downloading from MS...non-stop

      Definately not, only 1 language and only for the products we have. This has been in place over a two years without a problem.

      The only reason I suspected WSUS was becuase yesterday I moved the WSUS Storage Location, and becuase of the download location pointing to Microsoft.

      However since then it has clicked that according to the ISP the mass downloading started before I touched WSUS...also WSUS has now been removed and its still going.

      Is there anyway I can find out which process is handling the download?

      Comment


      • #4
        Re: Downloading from MS...non-stop

        Well, I was right...I think.

        I downloaded a the Trial of DUMeter. The Network Connections page said it was BITS that was the culprit...Windows own Background Intelligent Transfer Service for Windows Update.

        Tested by removing the bandwidth throttle and stopping + starting the service.

        I have disabled the service for now...but how do I torubleshoot this?

        Comment


        • #5
          Re: Downloading from MS...non-stop

          Just a small update, still no luck on how to go about troubleshooting this. Google doesnt seem to give me any leads on other occurence of this and how it was solved.

          I also want to reinstate WSUS but obviously I need to make sure this is fixed first.

          Appreciate any tips.

          Comment


          • #6
            Re: Downloading from MS...non-stop

            What else is running/installed on the server?
            A recent poll suggests that 6 out of 7 dwarfs are not happy

            Comment


            • #7
              Re: Downloading from MS...non-stop

              Its was originally a BES Server only, so literally nothing but the base install of Windows and BES.

              After that I installed WSUS, and it was working fine for years.

              That is all that is one it, its pretty clean to be honest.

              Comment


              • #8
                Re: Downloading from MS...non-stop

                Have you seen this article:

                http://technet.microsoft.com/en-us/l...73(WS.10).aspx
                A recent poll suggests that 6 out of 7 dwarfs are not happy

                Comment


                • #9
                  Re: Downloading from MS...non-stop

                  Looks ideal to try, thank you.

                  However on the first line Im supposed to type:

                  Code:
                  Type:
                  
                  Sc config bits binpath=”%systemroot%\system32\svchost.exe –k netsvcs“ Sc config bits depend = RpcSs EventSystem
                  
                  Sc config bits start=delayed-auto
                  
                  Sc config bits type=interact
                  
                  Sc config bits error=normal
                  
                  Sc config bits obj=LocalSystem
                  
                  Sc privs bits privileges=SeCreateGlobalPrivilege/SeImpersonatePrivilege/SeTcbPrivilege/SeAssignPrimaryTokenPrivilege/SeIncreateQuotaPrivilege
                  
                  Sc sidtype bits type= unrestricted
                  
                  Sc failure bits reset= 86400 actions=restart/60000/restart/120000
                  I get a syntax error in command prompt...

                  Comment


                  • #10
                    Re: Downloading from MS...non-stop

                    Check out this article which places them on separate lines:

                    http://technet.microsoft.com/en-us/l...22(WS.10).aspx
                    A recent poll suggests that 6 out of 7 dwarfs are not happy

                    Comment


                    • #11
                      Re: Downloading from MS...non-stop

                      Hi Blood

                      I did actually clock that and tried it on seperate lines as well, but same syntax error.

                      I also tried it with the service running and stopped.

                      Command prompt opened normally and Run As administrator.

                      Also tried changing %systemroot% to C:\windows, tried without quotes etc.

                      Really doesnt like this command :/

                      Comment


                      • #12
                        Re: Downloading from MS...non-stop

                        Wow never mind all I needed was a space after the = sign...

                        Speaking too soon. Every command works with some rejigging (spaces) except
                        # Sc config bits start=delayed-auto
                        # Sc config bits type=interact
                        # Sc privs bits privileges=SeCreateGlobalPrivilege/SeImpersonatePrivilege/SeTcbPrivilege/SeAssignPrimaryTokenPrivilege/SeIncreateQuotaPrivilege

                        These 3. Delayed-autoworks as auto only. Last 2 wont work at all and Im scared of continuing in case those lines need to be entered first.
                        Last edited by hongman; 10th July 2009, 16:19.

                        Comment


                        • #13
                          Re: Downloading from MS...non-stop

                          I've never needed to repair BITS, but I think you can run the commands without any problems. MS are not going to print stuff that may actually damage your PC.

                          If you are certain that BITS is the culprit then you certainly won't lose anything by trying.
                          A recent poll suggests that 6 out of 7 dwarfs are not happy

                          Comment


                          • #14
                            Re: Downloading from MS...non-stop

                            Thats what Im saying, some of those commands dont work and I had to change something in every line (add a space).

                            Comment


                            • #15
                              Re: Downloading from MS...non-stop

                              Do you get syntax errors when you try to run the commands or are commands simply not recognised?

                              Also, although I'm no expert on this it sounds as though your installation of BITS may have something seriously wrong with it. Perhaps you can try uninstalling and reinstalling BITS?

                              http://technet.microsoft.com/en-us/l...36(WS.10).aspx

                              There's also some info here that might be useful:

                              http://support.microsoft.com/kb/916251
                              A recent poll suggests that 6 out of 7 dwarfs are not happy

                              Comment

                              Working...
                              X