No announcement yet.

Permissions, IIS FTP..puzzle!

  • Filter
  • Time
  • Show
Clear All
new posts

  • Permissions, IIS FTP..puzzle!

    Hi there,
    I was at a site today and spent a while banging my head against a brick wall metaphorically. The site is running an SBS 2003 server that is only a few months old.
    They have a Konica bizhub c450 that was set up at a different site and has been moved over to be used as a joint printer/scanner/photocopier/blah blah.

    Everything is working except the scanner.

    The scanner is to be set up to save to a share on the server and worked fine at the old site. After modifying the server IP and the user/password it simply refuses to work.

    The share is \\server\scan and I've tried the admin username/password along with a dedicated username/password for the scanner. I've changed the path to longer and shorter names but nothing.

    The share itself is set fine with the everyone group having full control in both security and the share. It works fine from the pcs.

    So I'm left with a scanner that works fine on a different network and a server that works fine with everything but the scanner. The scanner supplier went through everything they could then blamed the server.

    I ran a chkdsk on the data partition that the share is in as I have seen filesystem problems cause strange access problems. I also verified the quotas.

    Finally, I decided to try and set up ftp through IIS and have the scanner save to that in a last ditch attempt to dodge the problem as no fix seemed to be in site. This yeilded errors saying "Unable to change to home directory" when attempting to login.

    This is the only thing that has given me an indication that there may be something not right with the server...but I have no idea what. I've reconfigured all the FTP stuff remotely and can connect on localhost but can't test the scanner remotely.

    Can anyone suggest any checks on the share that I haven't covered? (Yes, it has been deleted and recreated on different partitions. Not on a different machine though as I ran out of time)

  • #2
    Re: Permissions, IIS FTP..puzzle!

    First, is the server in a domain? If so, add Domain Users to permissions to allow access to share/ntfs permissions

    If not, and its in a workgroup, then you need to add all the usernames / passwords to the local SAM database - see Computer Management console.
    Alternatively, enable the user 'Guest' and allow that user to access the share.


    • #3
      Re: Permissions, IIS FTP..puzzle!

      Its a domain and I've tried all manner of permissions. Users, Everyone, Authenticated Users. Even manually specifying each account in the permissions. I didn't try the guest account though but the scanner requires a username and password (can't leave either blank).


      • #4
        Re: Permissions, IIS FTP..puzzle!

        Don't get FTP mixed up in the problem as it's a completely different protocol with different commands and parameters than normal file sharing. When you attempt to scan to the shared folder are you sure it's finding the share? Have you double checked the ip settings (address, mask, gateway) on the scanner?


        • #5
          Re: Permissions, IIS FTP..puzzle!

          The reason I put the FTP in was because attempting to use the FTP daemon was also getting an error trying to access the folder and that was using the manual ftp client from a PC.

          As far as the scanner goes, all it says is "Login Failed" which isn't exactly useful however I know that its on the network fine as it is installed to the server as a printer and connected to all the PCs using a kixtart login script.

          The server is and the scanner both with a /24 subnet and the server is referenced by IP address not hostname so no DNS issue.


          • #6
            Re: Permissions, IIS FTP..puzzle!

            Is it worthhwile checking the manual out??

            Last edited by wullieb1; 26th June 2009, 11:25.


            • #7
              Re: Permissions, IIS FTP..puzzle!

              Is the Konica setup to use groups and passwords so that each user has to login when photocopying/scanning?

              I had the same issue where I work. It took two months before the supplier's engineers admitted defeat. The only thing that solved it was to disable the local security on the Konica device.

              The logs on the Konica showed login failures when trying to scan to either SMB or to FTP.

              Another thing you may want to check is that the IP address of the device is recognised. In my case the Konica had a Fiery Controller attached. The controller has it's own DHCP service which assigns an address to the main Konica device. Therefore, we have to power on the controller first, allow it to boot properly so that the DHCP engine is working, then power on the main device. If you don't do this, it grabs an IP address that is not related to the local network. Also, the IP address of the Fiery must be correct.

              Good luck
              A recent poll suggests that 6 out of 7 dwarfs are not happy