No announcement yet.

2003 AD Domain not findable via NETBIOS

  • Filter
  • Time
  • Show
Clear All
new posts

  • 2003 AD Domain not findable via NETBIOS

    I have a small network of 7 PCs that were hooked up to an AD Windows 2000 server. The server needed replacing so I got a new one with Windows Server 2003. I ran through the proper steps of forestprep and adprep, add the new server as a DC allowed time for everything to replicate, transferred FSMO roles and the GC and then finally decommissioned AD off the old server and removed it. Everything went swimmingly, (first time I've ever had it go so smoothly, I think because its the first time I did all the right steps and in the right order). Everything seems perfect except for one irritating thing... I can no longer come into the office with my laptop, plug into the ethernet and browse to the new server!

    The old server was called MAIN and the domain had a short name of AREP and a FQDN of When I came in with my XP Pro laptop and went to My Network Places and view entire network, I would see a workgroup called AREP. Double click on it and I'd get the server MAIN, double click on it, login with username and password and I'd see and could open all the shares.

    The new server is called MAIN2, while the domain name and FQDN obviously remained the same. But now when I go to My Network Places there is no workgroup AREP listed.

    If I type in the address bar manually "\\main2" I get "Windows cannot find '\\main2'". I'm getting DHCP from the router, not the server (which was the same before the upgrade), so if I change my DNS to manually point to the local IP address of the server (which is, then I still get NO workgroup AREP, I still can't type in manually "\\main2", but now I CAN type in the FQDN "\\" and I get a prompt for login and password and can now get in that way.

    Through much experimentation I found that if I enter the command:
    nbtstat -A
    (again is the address of the server), I can THEN type in "\\main2" because nbtstat loaded it into the cache, but that only lasts for 560 seconds I believe and then the cache is cleared, so I have to do it again next time I want to get access.

    Also, if I change the workgroup on my laptop to "AREP", then when I go to My Network Places and double-click on the workgroup AREP I get the error message that "AREP is not accessible. You might not have permission to use this network resource".

    The office has a couple of computers that belong to a different company but I like for them to be able to access a couple shares on the server so I had them set as members of the AREP workgroup. I also have 5 Macs which I also had setup to be members of the AREP workgroup. They all worked fine under Windows 2000 Server but no longer. The only way I can give them permanent connections to the server is to map drives directly to the IP address "\\\share".

    Does anybody know what changed between Windows 2000 Server and Windows Server 2003 that caused this and if there is any way to fix?
    Last edited by rwhirn; 29th May 2009, 01:17.

  • #2
    Re: 2003 AD Domain not findable via NETBIOS

    Despite the fact that you have only half a dozen clients, i'd say configure your server as a WINS server and either point the clients to it or configure your DNS server to do a WINS lookup.
    How is your current DNS setup?
    Caesar's cipher - 3




    • #3
      Re: 2003 AD Domain not findable via NETBIOS

      I'm not sure what you mean by "how is it setup". I didn't do anything special with it. Just accepted the defaults. So its a basic AD DNS.

      I just installed WINS on the server but haven't yet done any changes to the workstations. I'm not sure that will help with the Macs though. I don't think they have a WINS feature. And that doesn't get to the root of the problem, which is how can anyone come in with a non-member laptop and get access to the workgroup to login and get to shares.?


      • #4
        Re: 2003 AD Domain not findable via NETBIOS


        If your client PC is picking up a DHCP address from your router, have you modified the scope options to use MAIN2 as your DNS server?

        There are 10 types of people in the world: Those who understand binary, and those who don't...


        • #5
          Re: 2003 AD Domain not findable via NETBIOS

          Once you have WINS setup you need to update the scope options on your DHCP server to apply the address of your WINS server to all workstations (PCs only):

          044 = WINS (Netbios) server address
          046 = Netbios type ( e.g. 0x

          If you do not have a DHCP server, you will need to configure it on all the servers and workstations in TCP/IP Advanced settings.


          • #6
            Re: 2003 AD Domain not findable via NETBIOS

            Thanks everyone for the advice. I will try all these things.

            But, it still does not explain why I can't come in with a laptop and find the network. This is something I've done for years at all different client's offices. I just don't understand why it doesn't work anymore.

            I'm thinking its more in the security settings, as Windows Server tends to get more restrictive with each iteration. So I've been looking at Domain Security Policies and have tried changing things like "Allow Anonymous Connections" but haven't hit on the right combination yet.